0 Replies Latest reply on Aug 9, 2006 5:26 AM by Anders Carlsen

    EAR is broken after redeployment

    Anders Carlsen Newbie

      My EAR application (containing three sar archives, a war archive and a jar archive) deploys and runs like a dream.

      However after I redeploy the ear, the application is broken. I get no errors on redeployment, but when I try to access the web part of the application I get the following error:

      2006-08-09 11:20:16,352 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/dmmapp].[jsp]] Servlet.service() for servlet jsp threw exception
      java.lang.NullPointerException
       at org.jboss.ejb.plugins.local.BaseLocalProxyFactory.invokeHome(BaseLocalProxyFactory.java:327)
       at org.jboss.ejb.plugins.local.LocalHomeProxy.invoke(LocalHomeProxy.java:118)
       at $Proxy2259.create(Unknown Source)
       at com.netmill.dmmbase.bean.presentation.EmployeeBean.getEmployeeManager(EmployeeBean.java:778)
       at com.netmill.dmmbase.bean.presentation.EmployeeBean.getEmployeeId(EmployeeBean.java:254)
       at com.netmill.dmmbase.bean.presentation.WebSessionBean.getEmployeeId(WebSessionBean.java:376)
       at com.netmill.dmmbase.bean.presentation.WebSessionBean.getEmployeeId(WebSessionBean.java:367)
       at com.netmill.dmmbase.bean.presentation.WebSessionBean.getLanguage(WebSessionBean.java:459)
       at org.apache.jsp.error.error500_jsp._jspService(org.apache.jsp.error.error500_jsp:106)
       at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)
       at javax.servlet.http.HttpServlet.service(HttpServlet.java:810)
       at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:322)
       at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:314)
       at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:264)
       at javax.servlet.http.HttpServlet.service(HttpServlet.java:810)
       at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
       at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
       at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:672)
       at org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:465)
       at org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:398)
       at org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:301)
       at org.apache.catalina.core.StandardHostValve.custom(StandardHostValve.java:362)
       at org.apache.catalina.core.StandardHostValve.status(StandardHostValve.java:283)
       at org.apache.catalina.core.StandardHostValve.throwable(StandardHostValve.java:227)
       at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:134)
       at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
       at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
       at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
       at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856)
       at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:744)
       at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
       at org.apache.tomcat.util.net.MasterSlaveWorkerThread.run(MasterSlaveWorkerThread.java:112)
       at java.lang.Thread.run(Thread.java:595)


      Seems to me like I can no longer access the EJB beans for some reason.

      Any help will be greatly appeciated...