1 2 Previous Next 19 Replies Latest reply on Dec 8, 2006 11:19 AM by Vladimir Ralev

    JEMS Installer 1.2.0.CR1: Errors when starting JBoss

    Juergen Zimmermann Master

      I installed JEMS 1.2.0.CR1. There was no problem.

      However, when I try to start JBoss I get the following error messages. Any hint is appreciated

      ...
      16:23:42,873 INFO [TomcatDeployer] deploy, ctxPath=/web-console, warUrl=.../deploy/management/console-mgr.sar/web-console.war/
      16:23:43,634 INFO [[/web-console]] MonitorsFolder: Failed to init plugin, null
      16:23:43,644 INFO [[/web-console]] UCLs: Failed to init plugin, null
      16:23:43,664 INFO [[/web-console]] JMS Message: Failed to init plugin, null
      16:23:43,664 INFO [[/web-console]] JSR77 WebModule: Failed to init plugin, null
      16:23:43,724 INFO [[/web-console]] J2EEFolder: Failed to init plugin, null
      16:23:43,754 INFO [[/web-console]] AOPFolder: Failed to init plugin, null
      16:23:43,754 INFO [[/web-console]] SystemFolder: Failed to init plugin, null
      16:23:43,804 INFO [[/web-console]] MBeans: Failed to init plugin, null
      16:23:43,814 INFO [[/web-console]] JSR77 Domains and Servers: Failed to init plugin, null
      16:23:43,814 INFO [[/web-console]] JSR77 EJBModules and EJBs: Failed to init plugin, null
      16:23:43,824 INFO [[/web-console]] JSR77 J2EE Apps: Failed to init plugin, null
      16:23:47,870 INFO [MailService] Mail Service bound to java:/Mail
      ...


        • 1. Re: JEMS Installer 1.2.0.CR1: Errors when starting JBoss
          Alex Pinkin Newbie

          Which profile did you select? Did you modify default component (file pack) selections?

          • 2. Re: JEMS Installer 1.2.0.CR1: Errors when starting JBoss
            C J Newbie

            I also get the same message after installing JBOSS 4.0.5GA with EJB3 support from the JEMS installer.

            I can deploy an application but I'm not able to deploy a simple EJB3 app.

            I think these errors messages maybe the cause.

            • 3. Re: JEMS Installer 1.2.0.CR1: Errors when starting JBoss
              C J Newbie

              Just to clarify, I'm using the same installer and (possibly due to the same errors) I'm not able to deploy a simply EJB3 component. The ear can deploy ok but the EJB3Deployer does not seem to pick up and load the EJB3.

              • 4. Re: JEMS Installer 1.2.0.CR1: Errors when starting JBoss
                Juergen Zimmermann Master

                I also selected the ejb3 profile.

                Deployment of an EAR file is no problem. The contained web app works.

                HOWEVER, remote EJB3 clients in a separate Java VM don't work. They cannot find remote session beans via JNDI

                • 5. Re: JEMS Installer 1.2.0.CR1: Errors when starting JBoss
                  Vladimir Ralev Newbie

                  Hello Juergen Zimmermann,

                  If you are running two instances of the AS on the same machine or configured non-default ports see http://jira.jboss.com/jira/browse/JBAS-3309

                  If this is not the case, in the jmx-console, see the list of the JNDI viewable items and make sure your bean is visible: http://localhost:8080/jmx-console/HtmlAdaptor?action=inspectMBean&name=jboss%3Aservice%3DJNDIView

                  Are there any exceptions displayed in the console, like "incompatible versions" or some thing else?

                  • 6. Re: JEMS Installer 1.2.0.CR1: Errors when starting JBoss
                    Vladimir Ralev Newbie

                    Hi cjindahouse,

                    Can you send me an undeployable ejb3 jar? (to vladimir.ralev@jboss.com)

                    If not, could you please try the EJB 3 trailblazer app http://www.jboss.com/docs/trailblazer and let me know if it works. You can try to only deploy the beans.jar inside the ear, if you think it works with ears, but not with plain ejb3-jars (it should work either ways).

                    • 7. Re: JEMS Installer 1.2.0.CR1: Errors when starting JBoss
                      Juergen Zimmermann Master

                      1) There is only one instance of JBossAS.

                      2) I'm just using an EAR which works fine with JEMS 1.2.0beta3.
                      Having troubles with JEMS 1.2.0CR1, of course I inspected /jmx-console. The JNDI names for the session beans are there. I cannot find any strange items or names. Anyway, the session beans cannot be accessed from a remote client (running on the same machine). I tried it with and w/o internet access.

                      BTW, the working web app uses the local interfaces of the session beans (EJB3).

                      • 8. Re: JEMS Installer 1.2.0.CR1: Errors when starting JBoss
                        C J Newbie

                        From looking at my logs, it appeared that the EJB3Deployer was just not working. So I had a look through the config files for something related to the EJB3Deployer.
                        I found one reference to the EJB3Deployer within my fresh jboss installation. The following code was commented out in ./server/default/deploy/jbossws14.sar/META-INF/jboss-service.xml
                        By uncommenting it, the EJB3Deployer picked up the EJBs in my EAR and I was able to deploy the EJB3 module and view the EJB3's in the JMX console. Please note this code was commented out as part of the installer for ejb3 support.

                         <mbean name="jboss.ws:service=DeployerInterceptorEJB3" code="org.jboss.ws.integration.jboss.DeployerInterceptorEJB3">
                         <depends-list optional-attribute-name="Interceptables">
                         <depends-list-element>jboss.ejb3:service=EJB3Deployer</depends-list-element>
                         </depends-list>
                         </mbean>
                        


                        Is this supposed to have been commented out?

                        However, the next issue is that I'm not able to lookup my EJB3 beans from the web app within the EAR using local interfaces.

                        Possibly another configuration issue?

                        Thanks for your quick responses.
                        Cheers.

                        • 9. Re: JEMS Installer 1.2.0.CR1: Errors when starting JBoss
                          Vladimir Ralev Newbie

                          cjindahouse

                          You are using some 1.4 server with ejb3 disabled. Make sure you are using a server installed by the JEMS Installer AND have selected the "ejb3" or the "ejb3-clustered" install profile.

                          • 10. Re: JEMS Installer 1.2.0.CR1: Errors when starting JBoss
                            Franc Giovinazzo Newbie

                            I'm getting the same error and my default profile is "ejb3". I'm running some sample apps on Netbeans 5.5 against JBoss 4.0.5 on a Mac.

                            What I've noticed is that the errors all relate to sevlets located in the deployment descriptor found under ./deploy/management/console-mgr.sar/web-console.war. They're set to load on startup, but it appears these are not being loaded correctly, causing the errors.

                            • 11. Re: JEMS Installer 1.2.0.CR1: Errors when starting JBoss
                              C J Newbie

                              Ok, I downloaded another version using the JEMS installer and this config file was fine.
                              Vladimir - I've installed several version of JBOSS and it's possible that I was using an "all" installation rather than the "ejb3" install.

                              Good news, I can deploy my EJB3 annotated session beans and view them from the JMX console, however the EJB3 entity bean is not registered in JMX.

                              I noticed that the EJBContainer throws a log message after deploying a bean..
                              ""10:26:54,318 INFO [EJBContainer] STARTED EJB: ......"
                              and that this message appears for my sessions beans, but not for my entity bean.

                              10:26:51,766 INFO [Ejb3Configuration] found EJB3 Entity bean: com.asdf.rightnow.RightnowRegistration
                              10:26:51,785 WARN [Ejb3Configuration] Persistence provider caller does not implements the EJB3 spec correctly. PersistenceUnitInfo.getNewTempClassLoader() is null.
                              10:26:51,863 INFO [Configuration] Reading mappings from resource: META-INF/orm.xml
                              10:26:51,883 INFO [Ejb3Configuration] [PersistenceUnit: oracle-alive] no META-INF/orm.xml found
                              10:26:51,960 INFO [AnnotationBinder] Binding entity from annotated class: com.asdf.rightnow.RightnowRegistration
                              10:26:52,130 INFO [EntityBinder] Bind entity com.asdf.rightnow.RightnowRegistration on table registration
                              10:26:52,695 INFO [ConnectionProviderFactory] Initializing connection provider: org.hibernate.ejb.connection.InjectedDataSourceConnectionProvider
                              10:26:52,716 INFO [InjectedDataSourceConnectionProvider] Using provided datasource
                              10:26:53,275 INFO [SettingsFactory] RDBMS: Oracle, version: Oracle Database 10g Enterprise Edition Release 10.2.0.2.0 - 64bit Production
                              With the Partitioning, OLAP and Data Mining options
                              10:26:53,275 INFO [SettingsFactory] JDBC driver: Oracle JDBC driver, version: 10.1.0.2.0
                              10:26:53,315 INFO [Dialect] Using dialect: org.hibernate.dialect.HSQLDialect
                              10:26:53,340 INFO [TransactionFactoryFactory] Transaction strategy: org.hibernate.ejb.transaction.JoinableCMTTransactionFactory
                              10:26:53,360 INFO [TransactionManagerLookupFactory] instantiating TransactionManagerLookup: org.hibernate.transaction.JBossTransactionManagerLookup
                              10:26:53,380 INFO [TransactionManagerLookupFactory] instantiated TransactionManagerLookup
                              10:26:53,381 INFO [SettingsFactory] Automatic flush during beforeCompletion(): disabled
                              10:26:53,381 INFO [SettingsFactory] Automatic session close at end of transaction: disabled
                              10:26:53,381 INFO [SettingsFactory] JDBC batch size: 15
                              10:26:53,381 INFO [SettingsFactory] JDBC batch updates for versioned data: disabled
                              10:26:53,382 INFO [SettingsFactory] Scrollable result sets: enabled
                              10:26:53,401 INFO [SettingsFactory] JDBC3 getGeneratedKeys(): disabled
                              10:26:53,401 INFO [SettingsFactory] Connection release mode: auto
                              10:26:53,402 INFO [SettingsFactory] Default batch fetch size: 1
                              10:26:53,420 INFO [SettingsFactory] Generate SQL with comments: disabled
                              10:26:53,421 INFO [SettingsFactory] Order SQL updates by primary key: disabled
                              10:26:53,439 INFO [SettingsFactory] Query translator: org.hibernate.hql.ast.ASTQueryTranslatorFactory
                              10:26:53,460 INFO [ASTQueryTranslatorFactory] Using ASTQueryTranslatorFactory
                              10:26:53,460 INFO [SettingsFactory] Query language substitutions: {}
                              10:26:53,460 INFO [SettingsFactory] JPA-QL strict compliance: enabled
                              10:26:53,460 INFO [SettingsFactory] Second-level cache: enabled
                              10:26:53,460 INFO [SettingsFactory] Query cache: disabled
                              10:26:53,461 INFO [SettingsFactory] Cache provider: org.hibernate.cache.HashtableCacheProvider
                              10:26:53,462 INFO [SettingsFactory] Optimize cache for minimal puts: disabled
                              10:26:53,497 INFO [SettingsFactory] Structured second-level cache entries: disabled
                              10:26:53,522 INFO [SettingsFactory] Echoing all SQL to stdout
                              10:26:53,522 INFO [SettingsFactory] Statistics: disabled
                              10:26:53,522 INFO [SettingsFactory] Deleted entity synthetic identifier rollback: disabled
                              10:26:53,523 INFO [SettingsFactory] Default entity-mode: pojo
                              10:26:53,579 INFO [SessionFactoryImpl] building session factory
                              10:26:53,835 INFO [SessionFactoryObjectFactory] Not binding factory to JNDI, no JNDI name configured
                              10:26:53,854 INFO [NamingHelper] JNDI InitialContext properties:{java.naming.factory.initial=org.jnp.interfaces.NamingContextFactory, java.naming.factory.url.pkgs=org.jboss.naming:org.jnp.interfaces}
                              10:26:53,958 INFO [JmxKernelAbstraction] installing MBean: jboss.j2ee:ear=integration.ear,jar=integrate-ejb3.jar,name=RegistrationService,service=EJB3 with dependencies:
                              10:26:53,958 INFO [JmxKernelAbstraction] persistence.units:ear=integration.ear,jar=integrate-ejb3.jar,unitName=oracle-alive
                              10:26:54,129 INFO [EJBContainer] STARTED EJB: com.asdf.rightnow.RegistrationService ejbName: RegistrationService
                              10:26:54,163 INFO [SimpleStatefulCache] Initializing SimpleStatefulCache with maxSize: 100000 timeout: 300 for jboss.j2ee:ear=integration.ear,jar=integrate-ejb3.jar,name=RegistrationService,service=EJB3
                              10:26:54,183 INFO [JmxKernelAbstraction] installing MBean: jboss.j2ee:ear=integration.ear,jar=integrate-ejb3.jar,name=RightnowEmailReaderBean,service=EJB3 with dependencies:
                              10:26:54,183 INFO [JmxKernelAbstraction] persistence.units:ear=integration.ear,jar=integrate-ejb3.jar,unitName=oracle-alive
                              10:26:54,318 INFO [EJBContainer] STARTED EJB: com.asdf.rightnow.RightnowEmailReaderBean ejbName: RightnowEmailReaderBean
                              10:26:54,364 INFO [EJB3Deployer] Deployed: file:/jboss-4.0.5.GA-test-all/server/default/tmp/deploy/tmp11604integration.ear-contents/integrate-ejb3.jar
                              10:26:54,388 INFO [TomcatDeployer] deploy, ctxPath=/integrate, warUrl=.../tmp/deploy/tmp11604integration.ear-contents/integrate-exp.war/
                              10:26:54,590 INFO [EARDeployer] Started J2EE application: file:/jboss-4.0.5.GA-test-all/server/default/deploy/integration.ear
                              


                              Any ideas, is this a configuration problem? The EntityBean is quite simple.

                              thanks.

                              • 12. Re: JEMS Installer 1.2.0.CR1: Errors when starting JBoss
                                Vladimir Ralev Newbie

                                Juergen.Zimmermann

                                Can you give me some more details about your app? Are you sure the problem is in the JNDI lookup? How do you transfer the JNDI context to your remote client? Are you using the ejb-3 client jar and is it the version that comes with CR1 or it's from the the older installer? etc.. Some code or jars that can reproduce it are welcome too.

                                • 13. Re: JEMS Installer 1.2.0.CR1: Errors when starting JBoss
                                  Vladimir Ralev Newbie

                                  cjindahouse

                                  Have you tired the trailblazer beans? Are they OK?

                                  • 14. Re: JEMS Installer 1.2.0.CR1: Errors when starting JBoss
                                    Greg Sting Newbie

                                    Same here, as it is classified as info, I don't think it really matters

                                    1 2 Previous Next