2 Replies Latest reply on Feb 15, 2007 11:51 AM by Mick Knutson

    Getting Chainsaw to correctly read the JBoss log4j settings.

    Mick Knutson Newbie

      I am trying to get Chainsaw to work correctly. Right now, it reads my configuration that came standard with jb 4.0.4-ga.

      Here is a line from the console:

      14:52:09,627 INFO [STDOUT] 14:52:09,627 INFO [UserBackingBean] setUserManager()

      1. Chainsaw seems to put this whole line as the message, and not just "setUserManager()" like I would expect.

      2. JBoss seems to set [STDOUT] as the level instead of "DEBUG" like I would expect.

      3. Chainsaw has a null for the Class, but I would expect to see [UserBackingBean]

      4. Chainsaw seems to be able to get method information for each line, but I am unclear how to get that information and would love to get that.



      Here is the appender I created:

      <!-- Chainsaw -->



      <!-- The default pattern: Date Priority [Category] Message\n -->




        • 1. Re: Getting Chainsaw to correctly read the JBoss log4j setti
          jaikiran pai Master

          I havent used Chainsaw before, so i might not be of much help.

          2. JBoss seems to set [STDOUT] as the level instead of "DEBUG" like I would expect.


          You are seeing the [STDOUT] because i guess you are watching the console for the log messages. Look into the server.log file and you wont find this [STDOUT]. Also are you logging the messages at DEBUG level or at INFO level?



          • 2. Re: Getting Chainsaw to correctly read the JBoss log4j setti
            Mick Knutson Newbie

             

            "jaikiran" wrote:
            I havent used Chainsaw before, so i might not be of much help.

            2. JBoss seems to set [STDOUT] as the level instead of "DEBUG" like I would expect.


            You are seeing the [STDOUT] because i guess you are watching the console for the log messages. Look into the server.log file and you wont find this [STDOUT]. Also are you logging the messages at DEBUG level or at INFO level?



            I have both info & debug messages for different items. They show up in Chainsaw, but they ALL show up as INFO, even the debug shows up as INFO