0 Replies Latest reply on Oct 15, 2007 7:00 AM by Mohcine Mohcine

    Help déploying Axis2.war  in Jboss 4.2.1

    Mohcine Mohcine Newbie

      Hello Everyone
      i rellay have issues when déployin axis2.war in JbossAS
      the probleme is when uploading a webservice it shows several errors

      Error: org.apache.axis2.deployment.DeploymentException: Processing Operations Modules with an error of The following error occurred during schema generation: ServiceClass or ServiceObjectSupplier implmentation Object could not be found at org.apache.axis2.deployment.repository.util.ArchiveReader.processServiceGroup(ArchiveReader.java:147) at org.apache.axis2.deployment.ServiceDeployer.deploy(ServiceDeployer.java:79) at org.apache.axis2.deployment.DeploymentEngine.doDeploy(DeploymentEngine.java:582) at org.apache.axis2.deployment.repository.util.WSInfoList.update(WSInfoList.java:201) at org.apache.axis2.deployment.RepositoryListener.update(RepositoryListener.java:271) at org.apache.axis2.deployment.RepositoryListener.checkServices(RepositoryListener.java:189) at org.apache.axis2.deployment.RepositoryListener.startListener(RepositoryListener.java:265) at org.apache.axis2.deployment.scheduler.SchedulerTask.checkRepository(SchedulerTask.java:61) at org.apache.axis2.deployment.scheduler.SchedulerTask.run(SchedulerTask.java:68) at org.apache.axis2.deployment.scheduler.Scheduler$SchedulerTimerTask.run(Scheduler.java:76) at java.util.TimerThread.mainLoop(Unknown Source) at java.util.TimerThread.run(Unknown Source) Caused by: org.apache.axis2.deployment.DeploymentException: Processing Operations Modules with an error of The following error occurred during schema generation: ServiceClass or ServiceObjectSupplier implmentation Object could not be found at org.apache.axis2.deployment.ServiceBuilder.populateService(ServiceBuilder.java:381) at org.apache.axis2.deployment.repository.util.ArchiveReader.buildServiceGroup(ArchiveReader.java:98) at org.apache.axis2.deployment.repository.util.ArchiveReader.processServiceGroup(ArchiveReader.java:140) ... 11 more Caused by: org.apache.axis2.deployment.DeploymentException: The following error occurred during schema generation: ServiceClass or ServiceObjectSupplier implmentation Object could not be found at org.apache.axis2.deployment.ServiceBuilder.populateService(ServiceBuilder.java:346) ... 13 more Caused by: org.apache.axis2.deployment.DeploymentException: ServiceClass or ServiceObjectSupplier implmentation Object could not be found at org.apache.axis2.deployment.util.Utils.fillAxisService(Utils.java:291) at org.apache.axis2.deployment.ServiceBuilder.populateService(ServiceBuilder.java:342)

      another issue is when i restart the server the config files i add to axis are deleted each time
      any idea