0 Replies Latest reply on Jan 2, 2008 8:27 AM by Nicole Schweighardt

    JBoss 4.2.2: JMXException when starting JBoss withJBossTools

    Nicole Schweighardt Novice

      Hello,

      I´m new to Jboss and Jboss Tools and the mailing-list.
      Following problem I posted 2 days ago to the mailing list but received no answer; I don´t know if I took the right address?
      (jboss-user@lists.jboss.org)

      I hope, anybody can help me!! Thanks for that.

      I tried to start Jboss (4.2.2 GA) with Eclipse and Jboss Tools.
      I tried starting without any application, only JBoss and I wanted to look at the jmx-console.

      In the console there appears the message that the server started successfully.

      Output:

      13:43:16,613 INFO [Server] Starting JBoss (MX MicroKernel)...
      13:43:16,613 INFO [Server] Release ID: JBoss [Trinity] 4.2.2.GA (build: SVNTag=JBoss_4_2_2_GA date=200710221139)
      13:43:16,613 INFO [Server] Home Dir: C:\Programme\jboss-4.2.2.GA
      13:43:16,628 INFO [Server] Home URL: file:/C:/Programme/jboss-4.2.2.GA/
      13:43:16,628 INFO [Server] Patch URL: null
      13:43:16,628 INFO [Server] Server Name: default
      13:43:16,628 INFO [Server] Server Home Dir: C:\Programme\jboss-4.2.2.GA\server\default
      13:43:16,628 INFO [Server] Server Home URL: file:/C:/Programme/jboss-4.2.2.GA/server/default/
      13:43:16,628 INFO [Server] Server Log Dir: C:\Programme\jboss-4.2.2.GA\server\default\log
      13:43:16,628 INFO [Server] Server Temp Dir: C:\Programme\jboss-4.2.2.GA\server\default\tmp
      13:43:16,628 INFO [Server] Root Deployment Filename: jboss-service.xml
      13:43:17,082 INFO [ServerInfo] Java version: 1.6.0_03,Sun Microsystems Inc.
      13:43:17,082 INFO [ServerInfo] Java VM: Java HotSpot(TM) Client VM 1.6.0_03-b05,Sun Microsystems Inc.
      13:43:17,082 INFO [ServerInfo] OS-System: Windows XP 5.1,x86
      13:43:17,550 INFO [Server] Core system initialized
      13:43:20,175 INFO [WebService] Using RMI server codebase: http://127.0.0.1:8083/
      13:43:20,175 INFO [Log4jService$URLWatchTimerTask] Configuring from URL: resource:jboss-log4j.xml
      13:43:20,738 INFO [TransactionManagerService] JBossTS Transaction Service (JTA version) - JBoss Inc.
      13:43:20,738 INFO [TransactionManagerService] Setting up property manager MBean and JMX layer
      13:43:20,910 INFO [TransactionManagerService] Starting recovery manager
      13:43:20,988 INFO [TransactionManagerService] Recovery manager started
      13:43:20,988 INFO [TransactionManagerService] Binding TransactionManager JNDI Reference
      13:43:23,816 INFO [EJB3Deployer] Starting java:comp multiplexer
      13:43:24,207 INFO [STDOUT] no object for null
      13:43:24,207 INFO [STDOUT] no object for null
      13:43:24,238 INFO [STDOUT] no object for null
      13:43:24,253 INFO [STDOUT] no object for {urn:jboss:bean-deployer}supplyType
      13:43:24,253 INFO [STDOUT] no object for {urn:jboss:bean-deployer}dependsType
      13:43:26,410 INFO [NativeServerConfig] JBoss Web Services - Native
      13:43:26,410 INFO [NativeServerConfig] jbossws-native-2.0.1.SP2 (build=200710210837)
      13:43:27,566 INFO [Embedded] Catalina naming disabled
      13:43:27,722 INFO [AprLifecycleListener] The Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\Programme\Java\jre1.6.0_03\bin;.;C:\WINDOWS\Sun\Java\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\Programme\Java\jre1.6.0_03\bin\client;C:\Programme\Java\jre1.6.0_03\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Sun\AppServer\bin;;;øûýËå?|Kæ?|
      13:43:27,785 INFO [Http11Protocol] Initializing Coyote HTTP/1.1 on http-127.0.0.1-8080
      13:43:27,785 INFO [AjpProtocol] Initializing Coyote AJP/1.3 on ajp-127.0.0.1-8009
      13:43:27,785 INFO [Catalina] Initialization processed in 224 ms
      13:43:27,785 INFO [StandardService] Starting service jboss.web
      13:43:27,785 INFO [StandardEngine] Starting Servlet Engine: JBossWeb/2.0.1.GA
      13:43:27,832 INFO [Catalina] Server startup in 46 ms
      13:43:27,941 INFO [TomcatDeployer] deploy, ctxPath=/, warUrl=.../deploy/jboss-web.deployer/ROOT.war/
      13:43:28,722 INFO [TomcatDeployer] deploy, ctxPath=/invoker, warUrl=.../deploy/http-invoker.sar/invoker.war/
      13:43:28,847 INFO [TomcatDeployer] deploy, ctxPath=/jbossws, warUrl=.../deploy/jbossws.sar/jbossws-context.war/
      13:43:28,957 INFO [TomcatDeployer] deploy, ctxPath=/jbossmq-httpil, warUrl=.../deploy/jms/jbossmq-httpil.sar/jbossmq-httpil.war/
      13:43:29,707 INFO [TomcatDeployer] deploy, ctxPath=/web-console, warUrl=.../deploy/management/console-mgr.sar/web-console.war/
      13:43:30,097 INFO [MailService] Mail Service bound to java:/Mail
      13:43:30,285 INFO [RARDeployment] Required license terms exist, view META-INF/ra.xml in .../deploy/jboss-ha-local-jdbc.rar
      13:43:30,332 INFO [RARDeployment] Required license terms exist, view META-INF/ra.xml in .../deploy/jboss-ha-xa-jdbc.rar
      13:43:30,378 INFO [RARDeployment] Required license terms exist, view META-INF/ra.xml in .../deploy/jboss-local-jdbc.rar
      13:43:30,425 INFO [RARDeployment] Required license terms exist, view META-INF/ra.xml in .../deploy/jboss-xa-jdbc.rar
      13:43:30,503 INFO [RARDeployment] Required license terms exist, view META-INF/ra.xml in .../deploy/jms/jms-ra.rar
      13:43:30,550 INFO [RARDeployment] Required license terms exist, view META-INF/ra.xml in .../deploy/mail-ra.rar
      13:43:30,597 INFO [RARDeployment] Required license terms exist, view META-INF/ra.xml in .../deploy/quartz-ra.rar
      13:43:30,613 INFO [QuartzResourceAdapter] start quartz!!!
      13:43:30,675 INFO [SimpleThreadPool] Job execution threads will use class loader of thread: main
      13:43:30,707 INFO [QuartzScheduler] Quartz Scheduler v.1.5.2 created.
      13:43:30,707 INFO [RAMJobStore] RAMJobStore initialized.
      13:43:30,707 INFO [StdSchedulerFactory] Quartz scheduler 'DefaultQuartzScheduler' initialized from default resource file in Quartz package: 'quartz.properties'
      13:43:30,707 INFO [StdSchedulerFactory] Quartz scheduler version: 1.5.2
      13:43:30,707 INFO [QuartzScheduler] Scheduler DefaultQuartzScheduler_$_NON_CLUSTERED started.
      13:43:31,894 INFO [ConnectionFactoryBindingService] Bound ConnectionManager 'jboss.jca:service=DataSourceBinding,name=DefaultDS' to JNDI name 'java:DefaultDS'
      13:43:32,144 INFO [A] Bound to JNDI name: queue/A
      13:43:32,144 INFO [B] Bound to JNDI name: queue/B
      13:43:32,144 INFO [C] Bound to JNDI name: queue/C
      13:43:32,144 INFO [D] Bound to JNDI name: queue/D
      13:43:32,144 INFO [ex] Bound to JNDI name: queue/ex
      13:43:32,160 INFO [testTopic] Bound to JNDI name: topic/testTopic
      13:43:32,175 INFO [securedTopic] Bound to JNDI name: topic/securedTopic
      13:43:32,175 INFO [testDurableTopic] Bound to JNDI name: topic/testDurableTopic
      13:43:32,175 INFO [testQueue] Bound to JNDI name: queue/testQueue
      13:43:32,207 INFO [UILServerILService] JBossMQ UIL service available at : /127.0.0.1:8093
      13:43:32,238 INFO [DLQ] Bound to JNDI name: queue/DLQ
      13:43:32,347 INFO [ConnectionFactoryBindingService] Bound ConnectionManager 'jboss.jca:service=ConnectionFactoryBinding,name=JmsXA' to JNDI name 'java:JmsXA'
      13:43:32,394 INFO [TomcatDeployer] deploy, ctxPath=/jmx-console, warUrl=.../deploy/jmx-console.war/
      13:43:32,613 INFO [Http11Protocol] Starting Coyote HTTP/1.1 on http-127.0.0.1-8080
      13:43:32,628 INFO [AjpProtocol] Starting Coyote AJP/1.3 on ajp-127.0.0.1-8009
      13:43:32,644 INFO [Server] JBoss (MX MicroKernel) [4.2.2.GA (build: SVNTag=JBoss_4_2_2_GA date=200710221139)] Started in 16s:16ms

      But in the Event log there appears following error:

      JMXException: Could not obtain connection to any of these urls: localhost:1099 and discovery failed with error: javax.naming.CommunicationException: Receice timed out [Root exception is java.net.SocketTimeoutException: Receive timed out]

      I tried it without running my firewall, it´s the same.

      I tried to run JBoss with the run.bat.
      If I do that the only message that appears is "Syntax error".

      I use Windows XP
      Eclipse 3.3 (Europa Release with WTP 2.0)
      JBoss Tools 2.0

      Thank you very much for your help.

      Greetings, NSchweig