0 Replies Latest reply on Jun 10, 2009 5:51 AM by Sam Wan

    Can't install Hibernate tools into Eclipse 3.4.1

    Sam Wan Newbie

      Hi,

      With eclipse 3.4.1, I tried to install Hibernate Tools from JBoss
      Tools 3.1.0M1-N200906090001-H244 (Development Release) to the eclipse
      IDE, but it failed with the following errors:

      Cannot complete the request. See the details.
      Unsatisfied dependency: [org.hibernate.eclipse.feature.feature.group
      3.3.0.M1-N200906090001-H244] requiredCapability:
      org.eclipse.equinox.p2.iu/org.eclipse.wst.xml.core/1.1.0
      Unsatisfied dependency: [org.hibernate.eclipse.feature.feature.group
      3.3.0.M1-N200906090001-H244] requiredCapability:
      org.eclipse.equinox.p2.iu/org.eclipse.wst.sse.core/1.1.0
      Unsatisfied dependency: [org.hibernate.eclipse.feature.feature.group
      3.3.0.M1-N200906090001-H244] requiredCapability:
      org.eclipse.equinox.p2.iu/org.eclipse.wst.dtd.core/1.1.0
      Unsatisfied dependency: [org.hibernate.eclipse.feature.feature.group
      3.3.0.M1-N200906090001-H244] requiredCapability:
      org.eclipse.equinox.p2.iu/org.eclipse.wst.common.project.facet.core/1.1.0
      Unsatisfied dependency: [org.hibernate.eclipse.feature.feature.group
      3.3.0.M1-N200906090001-H244] requiredCapability:
      org.eclipse.equinox.p2.iu/org.eclipse.wst.sse.ui/1.0.101
      Unsatisfied dependency: [org.hibernate.eclipse.feature.feature.group
      3.3.0.M1-N200906090001-H244] requiredCapability:
      org.eclipse.equinox.p2.iu/org.eclipse.wst.common.ui/1.1.0
      Unsatisfied dependency: [org.hibernate.eclipse.feature.feature.group
      3.3.0.M1-N200906090001-H244] requiredCapability:
      org.eclipse.equinox.p2.iu/org.eclipse.wst.xml.ui/1.0.100
      Unsatisfied dependency: [org.hibernate.eclipse.feature.feature.group
      3.3.0.M1-N200906090001-H244] requiredCapability:
      org.eclipse.equinox.p2.iu/org.eclipse.wst.common.project.facet.ui/1.1.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.jpt.core
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.wst.validation/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.jpt.core
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.jpt.core/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.console
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.jpt.core/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.jpt.ui
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.jpt.core/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.mapper
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.wst.dtd.core/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.mapper
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.wst.xml.ui/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.mapper
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.wst.sse.core/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.jpt.ui
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.jpt.ui/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.console
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.datatools.connectivity.ui/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.console
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.datatools.connectivity.ui/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.jpt.core
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.jpt.utility/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.jpt.ui
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.jpt.utility/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.mapper
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.wst.sse.ui/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.jpt.core
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.wst.common.project.facet.core/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.console
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.wst.common.project.facet.core/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.mapper
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.wst.common.ui/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.mapper
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.wst.xml.core/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.jpt.core
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.jpt.db/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.console
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.jpt.db/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.datatools.connectivity/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.console
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.datatools.connectivity/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.console
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.datatools.connectivity/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.jpt.ui
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.datatools.connectivity/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.console
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.wst.common.project.facet.ui/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.jpt.ui
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.wst.common.project.facet.ui/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.jpt.core
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.wst.validation/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.jpt.core
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.jpt.core/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.console
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.jpt.core/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.console
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.datatools.connectivity.ui/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.console
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.datatools.connectivity.ui/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.jpt.core
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.jpt.utility/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.jpt.core
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.wst.common.project.facet.core/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.console
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.wst.common.project.facet.core/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.jpt.core
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.jpt.db/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.console
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.jpt.db/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.console
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.datatools.connectivity/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.console
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.datatools.connectivity/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.datatools.connectivity/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.console
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.wst.common.project.facet.ui/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.feature.feature.group
      3.3.0.M1-N200906090001-H244] requiredCapability:
      org.eclipse.equinox.p2.iu/org.eclipse.wst.common.project.facet.ui/1.1.0
      Unsatisfied dependency: [org.hibernate.eclipse.feature.feature.group
      3.3.0.M1-N200906090001-H244] requiredCapability:
      org.eclipse.equinox.p2.iu/org.jboss.tools.hibernate.ui.view/[3.3.0.M1-N200906090001-H244,3.3.0.M1-N200906090001-H244]
      Unsatisfied dependency: [org.hibernate.eclipse.feature.feature.group
      3.3.0.M1-N200906090001-H244] requiredCapability:
      org.eclipse.equinox.p2.iu/org.eclipse.wst.xml.ui/1.0.100
      Unsatisfied dependency: [org.hibernate.eclipse.feature.feature.group
      3.3.0.M1-N200906090001-H244] requiredCapability:
      org.eclipse.equinox.p2.iu/org.eclipse.wst.sse.core/1.1.0
      Unsatisfied dependency: [org.hibernate.eclipse.feature.feature.group
      3.3.0.M1-N200906090001-H244] requiredCapability:
      org.eclipse.equinox.p2.iu/org.jboss.tools.hibernate.jpt.ui/[3.3.0.M1-N200906090001-H244,3.3.0.M1-N200906090001-H244]
      Unsatisfied dependency: [org.hibernate.eclipse.feature.feature.group
      3.3.0.M1-N200906090001-H244] requiredCapability:
      org.eclipse.equinox.p2.iu/org.eclipse.wst.xml.core/1.1.0
      Unsatisfied dependency: [org.hibernate.eclipse.feature.feature.group
      3.3.0.M1-N200906090001-H244] requiredCapability:
      org.eclipse.equinox.p2.iu/org.hibernate.eclipse.mapper/[3.3.0.M1-N200906090001-H244,3.3.0.M1-N200906090001-H244]
      Unsatisfied dependency: [org.hibernate.eclipse.feature.feature.group
      3.3.0.M1-N200906090001-H244] requiredCapability:
      org.eclipse.equinox.p2.iu/org.eclipse.wst.common.project.facet.core/1.1.0
      Unsatisfied dependency: [org.hibernate.eclipse.feature.feature.group
      3.3.0.M1-N200906090001-H244] requiredCapability:
      org.eclipse.equinox.p2.iu/org.hibernate.eclipse.console/[3.3.0.M1-N200906090001-H244,3.3.0.M1-N200906090001-H244]
      Unsatisfied dependency: [org.hibernate.eclipse.feature.feature.group
      3.3.0.M1-N200906090001-H244] requiredCapability:
      org.eclipse.equinox.p2.iu/org.jboss.tools.hibernate.jpt.core/[3.3.0.M1-N200906090001-H244,3.3.0.M1-N200906090001-H244]
      Unsatisfied dependency: [org.hibernate.eclipse.feature.feature.group
      3.3.0.M1-N200906090001-H244] requiredCapability:
      org.eclipse.equinox.p2.iu/org.jboss.tools.hibernate.ui.veditor/[3.3.0.M1-N200906090001-H244,3.3.0.M1-N200906090001-H244]
      Unsatisfied dependency: [org.hibernate.eclipse.feature.feature.group
      3.3.0.M1-N200906090001-H244] requiredCapability:
      org.eclipse.equinox.p2.iu/org.eclipse.wst.sse.ui/1.0.101
      Unsatisfied dependency: [org.hibernate.eclipse.feature.feature.group
      3.3.0.M1-N200906090001-H244] requiredCapability:
      org.eclipse.equinox.p2.iu/org.hibernate.eclipse.jdt.apt.ui/[3.3.0.M1-N200906090001-H244,3.3.0.M1-N200906090001-H244]
      Unsatisfied dependency: [org.hibernate.eclipse.feature.feature.group
      3.3.0.M1-N200906090001-H244] requiredCapability:
      org.eclipse.equinox.p2.iu/org.eclipse.wst.dtd.core/1.1.0
      Unsatisfied dependency: [org.hibernate.eclipse.feature.feature.group
      3.3.0.M1-N200906090001-H244] requiredCapability:
      org.eclipse.equinox.p2.iu/org.hibernate.eclipse.jdt.ui/[3.3.0.M1-N200906090001-H244,3.3.0.M1-N200906090001-H244]
      Unsatisfied dependency: [org.hibernate.eclipse.feature.feature.group
      3.3.0.M1-N200906090001-H244] requiredCapability:
      org.eclipse.equinox.p2.iu/org.eclipse.wst.common.ui/1.1.0
      Unsatisfied dependency: [org.hibernate.eclipse.feature.feature.group
      3.3.0.M1-N200906090001-H244] requiredCapability:
      org.eclipse.equinox.p2.iu/org.hibernate.eclipse/[3.3.0.M1-N200906090001-H244,3.3.0.M1-N200906090001-H244]
      Unsatisfied dependency: [org.jboss.tools.hibernate.ui.view
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.hibernate.eclipse/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.ui.view
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.hibernate.eclipse.console/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.ui.veditor
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.hibernate.eclipse/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.ui.veditor
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.hibernate.eclipse.console/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.ui.veditor
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.jboss.tools.hibernate.ui.view/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.datatools.connectivity/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.jdt.apt.ui
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.hibernate.eclipse.console/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.jdt.apt.ui
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.hibernate.eclipse/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.jdt.ui
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.hibernate.eclipse.console/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.jdt.ui
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.hibernate.eclipse/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.mapper
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.wst.common.ui/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.mapper
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.hibernate.eclipse.console/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.mapper
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.wst.xml.ui/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.mapper
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.wst.sse.core/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.mapper
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.wst.sse.ui/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.mapper
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.wst.xml.core/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.mapper
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.wst.dtd.core/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.mapper
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.hibernate.eclipse/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.jpt.core
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.jpt.utility/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.jpt.core
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.wst.common.project.facet.core/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.jpt.core
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.wst.validation/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.jpt.core
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.jpt.db/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.jpt.core
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.jpt.core/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.jpt.core
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.hibernate.eclipse.console/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.jpt.core
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.hibernate.eclipse/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.console
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.jpt.core/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.console
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.wst.common.project.facet.core/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.console
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.datatools.connectivity.ui/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.console
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.datatools.connectivity.ui/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.console
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.jpt.db/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.console
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.datatools.connectivity/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.console
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.hibernate.eclipse/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.console
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.wst.common.project.facet.ui/0.0.0
      Unsatisfied dependency: [org.hibernate.eclipse.console
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.datatools.connectivity/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.jpt.ui
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.jboss.tools.hibernate.jpt.core/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.jpt.ui
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.jpt.ui/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.jpt.ui
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.hibernate.eclipse.console/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.jpt.ui
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.wst.common.project.facet.ui/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.jpt.ui
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.jpt.core/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.jpt.ui
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.datatools.connectivity/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.jpt.ui
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.hibernate.eclipse/0.0.0
      Unsatisfied dependency: [org.jboss.tools.hibernate.jpt.ui
      3.3.0.M1-N200906090001-H244] requiredCapability:
      osgi.bundle/org.eclipse.jpt.utility/0.0.0

      What should I do about it? Considering this is s development release,
      Where can I download an older release of this plugin for eclipse
      3.4.1?

      Your help is very much appreciated

      Thanks