1 Reply Latest reply on Sep 19, 2003 3:31 PM by Amit Kirdatt

    mod_jk issues

    Amit Kirdatt Newbie

      First the environment:
      JBoss: jboss-3.2.1-tomcat-4.1.24
      JDK: IBM1.3.1
      OS: RedHat Linux AS 2.1
      4 nodes total

      We have 4 nodes running and need HttpSession failover. I tried mod_jk and mod_jk2. By, the way the most recent version of mod_jk2, apache2.0.47 and Jboss was a nightmare to get working. Anyways, I got the installation for mod_jk2 working but only when the Ajp port is listening on 8009. No matter what settings I put in the workers2.properties file it always wanted to connect on port 8009. Does anybody have this running?

      So I switched to mod_jk (Ajp13Connector instead of the CoyoteConnector) which works, but all the requests go to just one server. Also, we see errors on the webserver side of the logs generated by mod_jk saying the following:

      [Fri Sep 19 17:33:35 2003] [jk_ajp_common.c (1050)]: Error reading reply from tomcat. Tomcat is down or network problems.
      [Fri Sep 19 17:33:35 2003] [jk_ajp_common.c (1187)]: ERROR: Receiving from tomcat failed, recoverable operation. err=0

      I can telnet to all the Ajp ports and they are up and so is JBoss.

      So Does anybody have this working correctly?
      Also, we have the "pay for" docs, but it is outdated!
      Anyhelp from you guys would be appreciated.

      Thanks

        • 1. Re: mod_jk issues
          Amit Kirdatt Newbie

          Here is my workers2.properties file for the mod_jk2 stuff:

          [logger]
          level=INFO

          [config:]
          file=${serverRoot}/conf/workers2.properties
          debug=0
          debugEnv=0

          [uriMap:]
          info=Maps the requests. Options: debug
          debug=0

          [shm:]
          info=Scoreboard. Required for reconfiguration and status with multiprocess servers
          file=${serverRoot}/logs/jk2.shm
          size=1000000
          debug=0
          disabled=0

          [lb:lb]
          info=Default load balancer.
          debug=0

          # Define the communication channel
          [channel.socket:172.21.1.248:50065]
          port=50065
          host=172.21.1.248
          tomcatId=172.21.1.248:50065
          lb_factor=1
          group=lb

          [ajp13:172.21.1.248:50065]
          channel=channel.socket:172.21.1.248:50065

          # Map the Tomcat examples webapp to the web server uri space
          [uri:/myapp/*]
          worker=ajp13:172.21.1.248:50065
          info=Map the whole webapp
          group=lb
          debug=0