10 Replies Latest reply on Jan 19, 2004 9:13 PM by Tim Bauer

    Non-multicast cluster problem

    Todd Hough Newbie

       

      "toddh" wrote:
      "toddh" wrote:
      I'm running JBoss 3.2.2
      CVSTag=JBoss_3_2_2 date=200310182216

      I've configured cluster-service.xml with the following partition config:

      <attribute name="PartitionConfig">
      <Config>
      <TCP start_port="11800" />
      <TCPPING initial_hosts="localhost[12800]"
      port_range="5"
      timeout="3000"
      num_initial_members="2"
      up_thread="true"
      down_thread="true" />
      <VERIFY_SUSPECT timeout="1500"
      up_thread="false"
      down_thread="false" />
      <pbcast.STABLE desired_avg_gossip="20000"
      up_thread="false"
      down_thread="false" />
      <pbcast.NAKACK gc_lag="100"
      retransmit_timeout="3000"
      up_thread="true"
      down_thread="true" />
      <pbcast.GMS join_timeout="5000"
      join_retry_timeout="2000"
      shun="false"
      print_local_addr="false"
      up_thread="true"
      down_thread="true" />
      </Config>
      </attribute>

      When starting JBoss I get the following error:

      2003-11-24 17:12:52,086 INFO [org.jboss.deployment.MainDeployer] Starting deployment of package: file:/C:/Apps/JBoss-3.2.2/server/TravelHQ-Dev-1/deploy/cluster-service.xml
      2003-11-24 17:12:52,633 ERROR [org.jboss.ha.framework.server.ClusterPartition] Initialization failed
      ChannelException: JChannel(): java.lang.Exception: Configurator.sanityCheck(): event GET_DIGEST_STABLE is required by STABLE, but not provided by any of the layers below
      at org.jgroups.JChannel.<init>(JChannel.java:151)
      at org.jboss.ha.framework.server.ClusterPartition.createService(ClusterPartition.java:231)
      at org.jboss.system.ServiceMBeanSupport.create(ServiceMBeanSupport.java:158)
      at ...

      Any help is appreciated.
      Todd


        • 1. Re: Non-multicast cluster problem
          Tim Bauer Novice

           

          "tbauer" wrote:
          I too am having the same error using JBoss 3.2.3 on MacOS X 10.3.2

          my TCP setup is this:

          <TCP start_port="7800" bind_addr="63.193.224.220"/>
          <TCPPING initial_hosts="63.193.224.220[7800]"
          port_range="5"
          timeout="2000" num_initial_members="5"
          up_thread="true" down_thread="true" />
          <VERIFY_SUSPECT timeout="1500"
          up_thread="true" down_thread="true" />
          <pbcast.STABLE desired_avg_gossip="20000"
          up_thread="true" down_thread="true" />
          <pbcast.NAKACK gc_lag="50" retransmit_timeout="300,600,1200,2400,4800"
          up_thread="true" down_thread="true" />
          <pbcast.GMS join_timeout="5000" join_retry_timeout="2000"
          shun="true" print_local_addr="true" />

          Getting the same error as Todd...Is anyone at JBoss listening?? Bela??


          • 2. Re: Non-multicast cluster problem
            Tim Bauer Novice

             

            "tbauer" wrote:
            Why is there little (to NO) detailed documentation when you want to use TCP.
            All the docs mainly discuss UDP...JavaGroups.com has minimul comments:

            My cluser-service.xml starts with the following config that DOES work in
            3.2.1:

            <TCP start_port="7800" bind_addr="63.193.224.220"/>
            <TCPPING initial_hosts="63.193.224.220[7800]"
            port_range="5"
            timeout="2000" num_initial_members="5"
            up_thread="true" down_thread="true" />
            <VERIFY_SUSPECT timeout="1500"
            up_thread="true" down_thread="true" />
            <pbcast.STABLE desired_avg_gossip="20000"
            up_thread="true" down_thread="true" />
            <pbcast.NAKACK gc_lag="50" retransmit_timeout="300,600,1200,2400,4800"
            up_thread="true" down_thread="true" />
            <pbcast.GMS join_timeout="5000" join_retry_timeout="2000"
            shun="true" print_local_addr="true" />




            09:22:55,291 ERROR [ClusterPartition] Initialization failed
            ChannelException: JChannel(): java.lang.Exception: Configurator.sanityCheck(): event GET_DIGEST_STABLE is required by STABLE, but not provided by any of the layers below
            at org.jgroups.JChannel.<init>(JChannel.java:151)
            at org.jboss.ha.framework.server.ClusterPartition.createService(ClusterPartition.java:231)
            at org.jboss.system.ServiceMBeanSupport.create(ServiceMBeanSupport.java:158)
            at sun.reflect.GeneratedMethodAccessor5.invoke(Unknown Source)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:324)
            at org.jboss.mx.capability.ReflectedMBeanDispatcher.invoke(ReflectedMBeanDispatcher.java:284)
            at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:546)
            at org.jboss.system.ServiceController$ServiceProxy.invoke(ServiceController.java:976)
            at $Proxy14.create(Unknown Source)
            at org.jboss.system.ServiceController.create(ServiceController.java:310)
            at org.jboss.system.ServiceController.create(ServiceController.java:243)
            at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:324)
            at org.jboss.mx.capability.ReflectedMBeanDispatcher.invoke(ReflectedMBeanDispatcher.java:284)
            at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:546)
            at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java:177)
            at $Proxy4.create(Unknown Source)
            at org.jboss.deployment.SARDeployer.create(SARDeployer.java:192)
            at org.jboss.deployment.MainDeployer.create(MainDeployer.java:786)
            at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:641)
            at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:605)
            at sun.reflect.GeneratedMethodAccessor26.invoke(Unknown Source)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:324)
            at org.jboss.mx.capability.ReflectedMBeanDispatcher.invoke(ReflectedMBeanDispatcher.java:284)
            at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:546)
            at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java:177)
            at $Proxy6.deploy(Unknown Source)
            at org.jboss.deployment.scanner.URLDeploymentScanner.deploy(URLDeploymentScanner.java:302)
            at org.jboss.deployment.scanner.URLDeploymentScanner.scan(URLDeploymentScanner.java:476)
            at org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.doScan(AbstractDeploymentScanner.java:201)
            at org.jboss.deployment.scanner.AbstractDeploymentScanner.startService(AbstractDeploymentScanner.java:274)
            at org.jboss.system.ServiceMBeanSupport.start(ServiceMBeanSupport.java:192)
            at sun.reflect.GeneratedMethodAccessor9.invoke(Unknown Source)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:324)
            at org.jboss.mx.capability.ReflectedMBeanDispatcher.invoke(ReflectedMBeanDispatcher.java:284)
            at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:546)
            at org.jboss.system.ServiceController$ServiceProxy.invoke(ServiceController.java:976)
            at $Proxy0.start(Unknown Source)
            at org.jboss.system.ServiceController.start(ServiceController.java:394)
            at sun.reflect.GeneratedMethodAccessor8.invoke(Unknown Source)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:324)
            at org.jboss.mx.capability.ReflectedMBeanDispatcher.invoke(ReflectedMBeanDispatcher.java:284)
            at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:546)
            at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java:177)
            at $Proxy4.start(Unknown Source)
            at org.jboss.deployment.SARDeployer.start(SARDeployer.java:226)
            at org.jboss.deployment.MainDeployer.start(MainDeployer.java:832)
            at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:642)
            at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:605)
            at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:589)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:324)
            at org.jboss.mx.capability.ReflectedMBeanDispatcher.invoke(ReflectedMBeanDispatcher.java:284)
            at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:546)
            at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java:177)
            at $Proxy5.deploy(Unknown Source)
            at org.jboss.system.server.ServerImpl.doStart(ServerImpl.java:384)
            at org.jboss.system.server.ServerImpl.start(ServerImpl.java:291)
            at org.jboss.Main.boot(Main.java:150)
            at org.jboss.Main$1.run(Main.java:395)
            at java.lang.Thread.run(Thread.java:554)



            Cause: Incomplete Deployment listing:
            Packages waiting for a deployer:
            <none>
            Incompletely deployed packages:
            <none>
            MBeans waiting for classes:
            <none>
            MBeans waiting for other MBeans:
            [ObjectName: jboss.j2ee:jndiName=clustering/HTTPSession,service=EJB
            state: NOTYETINSTALLED
            I Depend On: jboss:service=DefaultPartition
            jboss:service=invoker,type=jrmp

            Depends On Me: jboss:service=ClusteredHttpSession
            , ObjectName: jboss:service=ClusteredHttpSession
            state: CONFIGURED
            I Depend On: jboss.j2ee:jndiName=clustering/HTTPSession,service=EJB

            Depends On Me: , ObjectName: jboss.mq:service=HAILSharedState
            state: CONFIGURED
            I Depend On: jboss:service=DefaultPartition

            Depends On Me: jboss.mq:service=InvocationLayer,type=HAIL
            , ObjectName: jboss.mq:service=InvocationLayer,type=HAIL
            state: CONFIGURED
            I Depend On: jboss.mq:service=InvocationLayer,type=UIL2
            jboss.mq:service=HAILSharedState

            Depends On Me: jboss.mq:service=HAILSingletonController
            , ObjectName: jboss.mq:service=HAILSingletonController
            state: CONFIGURED
            I Depend On: jboss:service=DefaultPartition
            jboss.mq:service=InvocationLayer,type=HAIL

            Depends On Me: , ObjectName: jboss:service=DefaultPartition
            state: FAILED
            I Depend On:
            Depends On Me: jboss.j2ee:jndiName=clustering/HTTPSession,service=EJB
            jboss.mq:service=HAILSharedState
            jboss.mq:service=HAILSingletonController
            jboss:service=HASessionState
            jboss:service=HAJNDI
            jboss.cache:service=InvalidationBridge,type=JavaGroups
            jboss:service=FarmMember,partition=DefaultPartition
            ChannelException: JChannel(): java.lang.Exception: Configurator.sanityCheck(): event GET_DIGEST_STABLE is required by STABLE, but not provided by any of the layers below, ObjectName: jboss:service=HASessionState
            state: CONFIGURED
            I Depend On: jboss:service=DefaultPartition

            Depends On Me: , ObjectName: jboss:service=HAJNDI
            state: CONFIGURED
            I Depend On: jboss:service=DefaultPartition

            Depends On Me: , ObjectName: jboss.cache:service=InvalidationBridge,type=JavaGroups
            state: CONFIGURED
            I Depend On: jboss:service=DefaultPartition
            jboss.cache:service=InvalidationManager

            Depends On Me: , ObjectName: jboss:service=FarmMember,partition=DefaultPartition
            state: CONFIGURED
            I Depend On: jboss:service=DefaultPartition
            jboss.web:service=WebServer
            jboss.system:service=MainDeployer


            • 3. Re: Non-multicast cluster problem
              Bela Ban Master

               

              "bela" wrote:
              You screwed up the config:-)

              1. UNICAST is missing. Why did you remove it ?
              2. STABLE needs to be *above* NAKACK, not below.
              3. TCPPING uses 'localhost' (127.0.0.1). This won't work in most cases

              I suggest you copy a recent cluster-service.xml config, then replace UDP:PING with TCP:TCPPING.
              Bela



              "toddh" wrote:
              I'm running JBoss 3.2.2
              CVSTag=JBoss_3_2_2 date=200310182216

              I've configured cluster-service.xml with the following partition config:

              <attribute name="PartitionConfig">
              <Config>
              <TCP start_port="11800" />
              <TCPPING initial_hosts="localhost[12800]"
              port_range="5"
              timeout="3000"
              num_initial_members="2"
              up_thread="true"
              down_thread="true" />
              <VERIFY_SUSPECT timeout="1500"
              up_thread="false"
              down_thread="false" />
              <pbcast.STABLE desired_avg_gossip="20000"
              up_thread="false"
              down_thread="false" />
              <pbcast.NAKACK gc_lag="100"
              retransmit_timeout="3000"
              up_thread="true"
              down_thread="true" />
              <pbcast.GMS join_timeout="5000"
              join_retry_timeout="2000"
              shun="false"
              print_local_addr="false"
              up_thread="true"
              down_thread="true" />
              </Config>
              </attribute>

              When starting JBoss I get the following error:

              2003-11-24 17:12:52,086 INFO [org.jboss.deployment.MainDeployer] Starting deployment of package: file:/C:/Apps/JBoss-3.2.2/server/TravelHQ-Dev-1/deploy/cluster-service.xml
              2003-11-24 17:12:52,633 ERROR [org.jboss.ha.framework.server.ClusterPartition] Initialization failed
              ChannelException: JChannel(): java.lang.Exception: Configurator.sanityCheck(): event GET_DIGEST_STABLE is required by STABLE, but not provided by any of the layers below
              at org.jgroups.JChannel.<init>(JChannel.java:151)
              at org.jboss.ha.framework.server.ClusterPartition.createService(ClusterPartition.java:231)
              at org.jboss.system.ServiceMBeanSupport.create(ServiceMBeanSupport.java:158)
              at ...

              Any help is appreciated.
              Todd


              • 4. Re: Non-multicast cluster problem
                Bela Ban Master

                 

                "bela" wrote:
                Move STABLE on top of NAKACK


                • 5. Re: Non-multicast cluster problem
                  Todd Hough Newbie

                   

                  "toddh" wrote:
                  Thanks tbauer for bumping this back up.

                  Bela, that worked like a charm. I'm not sure how I arrived at the configuration I posted. There was a lot of guessing and trial and error going on.

                  You might consider including a TCP section in cluster-service.xml that's commented out.

                  One thing that was non-intuitive, the TCPPING initial_hosts attribute didnt like it when I used my IP. With the IP it wouldn't give a deployment error but the cluster nodes didn't see each other. I changed it to the machine name and the nodes are able to connect.

                  For anyone else trying to get this to work, I replaced

                  <UDP mcast_addr="228.1.2.3" mcast_port="45566"
                   ip_ttl="64" ip_mcast="true"
                   mcast_send_buf_size="150000" mcast_recv_buf_size="80000"
                   ucast_send_buf_size="150000" ucast_recv_buf_size="80000"
                   loopback="false" />
                  <PING timeout="2000" num_initial_members="3"
                   up_thread="true" down_thread="true" />
                  


                  with this (server 1)

                  <TCP start_port="11800" />
                  <TCPPING initial_hosts="m6x27jyhz115l[12800]"
                   port_range="5"
                   timeout="3000"
                   num_initial_members="2"
                   up_thread="true"
                   down_thread="true" />
                  


                  and this (server 2)

                  <TCP start_port="12800" />
                  <TCPPING initial_hosts="m6x27jyhz115l[11800]"
                   port_range="5"
                   timeout="3000"
                   num_initial_members="2"
                   up_thread="true"
                   down_thread="true" />
                  


                  in cluster-service.xml. Where m6x27jyhz115l is my machine name and I'm running two instances of JBoss 3.2.3 on my machine with ports 11800 and 12800.


                  Anyway, thanks again Bela and tbauer.


                  • 6. Re: Non-multicast cluster problem
                    Tim Bauer Novice

                     

                    "tbauer" wrote:
                    Still not working..Here is the snippet from my cluster-service.xml:

                    <mbean code="org.jboss.ha.framework.server.ClusterPartition"
                    name="jboss:service=DefaultPartition">

                    <!-- Name of the partition being built -->
                    <attribute name="PartitionName">DefaultPartition</attribute>
                    <!-- Determine if deadlock detection is enabled -->
                    <attribute name="DeadlockDetection">False</attribute>
                    <!-- The JGroups protocol configuration -->
                    <attribute name="PartitionConfig">
                    <Config>
                    <!-- UDP: if you have a multihomed machine,
                    set the bind_addr attribute to the appropriate NIC IP address -->
                    <!-- UDP: On Windows machines, because of the media sense feature
                    being broken with multicast (even after disabling media sense)
                    set the loopback attribute to true -->
                    <TCP start_port="7800" bind_addr="63.193.224.220"/>
                    <TCPPING initial_hosts="63.193.224.220[7800]"
                    port_range="5"
                    timeout="2000" num_initial_members="5"
                    up_thread="true" down_thread="true" />
                    <MERGE2 min_interval="5000" max_interval="10000" />
                    <FD shun="true" up_thread="true" down_thread="true"
                    timeout="2500" max_tries="5" />
                    <VERIFY_SUSPECT timeout="3000" num_msgs="3"
                    up_thread="true" down_thread="true" />
                    <pbcast.STABLE desired_avg_gossip="20000"
                    up_thread="true" down_thread="true" />
                    <pbcast.NAKACK gc_lag="50" retransmit_timeout="300,600,1200,2400,4800"
                    up_thread="true" down_thread="true" />
                    <UNICAST timeout="5000" window_size="100" min_threshold="10"
                    down_thread="true" />
                    <FRAG frag_size="8192"
                    down_thread="true" up_thread="true" />
                    <pbcast.GMS join_timeout="5000" join_retry_timeout="2000"
                    shun="true" print_local_addr="true" />
                    <pbcast.STATE_TRANSFER up_thread="true" down_thread="true" />
                    </Config>
                    </attribute>
                    </mbean>

                    Still getting this error:

                    08:25:51,449 ERROR [ClusterPartition] Initialization failed
                    ChannelException: JChannel(): java.lang.Exception: Configurator.sanityCheck(): event GET_DIGEST_STABLE is required by STABLE, but not provided by any of the layers below
                    at org.jgroups.JChannel.<init>(JChannel.java:151)
                    at org.jboss.ha.framework.server.ClusterPartition.createService(ClusterPartition.java:231)
                    at org.jboss.system.ServiceMBeanSupport.create(ServiceMBeanSupport.java:158)
                    at sun.reflect.GeneratedMethodAccessor5.invoke(Unknown Source)
                    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                    at java.lang.reflect.Method.invoke(Method.java:324)


                    Bela, in the cluster-service.xml file I got from the baseline distribution,

                    <pbcast.STABLE was BELOW NAKACK...

                    Any clues as to what I am doing wrong???


                    • 7. Re: Non-multicast cluster problem
                      Tim Bauer Novice

                       

                      "tbauer" wrote:
                      toddh, could you please paste in your WHOLE TCP configuration section???

                      thanks,

                      Tim


                      • 8. Re: Non-multicast cluster problem
                        Todd Hough Newbie

                         

                        "toddh" wrote:
                        Are you running JBoss 3.2.3?

                        A couple of differences between our configs is that I didn't set TCP bind_addr and I had to use the name, not IP, in TCPPING initial_hosts.

                        Here's my whole cluster-service.xml but my previous post includes the part I changed. The rest of this is just the default cluster-service.xml included in JBoss 3.2.3 "all".

                        Be aware that I did chang the partition name to LocalPartition from DefaultPartition.

                        (Preview is only showing the top 10 lines of my code block but hopefully the full block will show in the post)
                        <?xml version="1.0" encoding="UTF-8"?>
                        
                        <!-- ===================================================================== -->
                        <!-- -->
                        <!-- Sample Clustering Service Configuration -->
                        <!-- -->
                        <!-- ===================================================================== -->
                        
                        <server>
                        
                         <classpath codebase="lib" archives="jbossha.jar"/>
                        
                         <!-- ==================================================================== -->
                         <!-- Cluster Partition: defines cluster -->
                         <!-- ==================================================================== -->
                        
                         <mbean code="org.jboss.ha.framework.server.ClusterPartition"
                         name="jboss:service=LocalPartition">
                        
                         <!-- Name of the partition being built -->
                         <attribute name="PartitionName">LocalPartition</attribute>
                         <!-- Determine if deadlock detection is enabled -->
                         <attribute name="DeadlockDetection">False</attribute>
                         <!-- The JGroups protocol configuration -->
                         <attribute name="PartitionConfig">
                         <Config>
                         <!-- UDP: if you have a multihomed machine,
                         set the bind_addr attribute to the appropriate NIC IP address -->
                         <!-- UDP: On Windows machines, because of the media sense feature
                         being broken with multicast (even after disabling media sense)
                         set the loopback attribute to true -->
                         <!--
                         <UDP mcast_addr="228.1.2.3" mcast_port="45566"
                         ip_ttl="64" ip_mcast="true"
                         mcast_send_buf_size="150000" mcast_recv_buf_size="80000"
                         ucast_send_buf_size="150000" ucast_recv_buf_size="80000"
                         loopback="false" />
                         <PING timeout="2000" num_initial_members="3"
                         up_thread="true" down_thread="true" />-->
                         <TCP start_port="11800" />
                         <TCPPING initial_hosts="m6x27jyhz115l[12800]"
                         port_range="5"
                         timeout="3000"
                         num_initial_members="2"
                         up_thread="true"
                         down_thread="true" />
                         <MERGE2 min_interval="5000" max_interval="10000" />
                         <FD shun="true" up_thread="true" down_thread="true"
                         timeout="2500" max_tries="5" />
                         <VERIFY_SUSPECT timeout="3000" num_msgs="3"
                         up_thread="true" down_thread="true" />
                         <pbcast.NAKACK gc_lag="50" retransmit_timeout="300,600,1200,2400,4800"
                         up_thread="true" down_thread="true" />
                         <pbcast.STABLE desired_avg_gossip="20000"
                         up_thread="true" down_thread="true" />
                         <UNICAST timeout="5000" window_size="100" min_threshold="10"
                         down_thread="true" />
                         <FRAG frag_size="8192"
                         down_thread="true" up_thread="true" />
                         <pbcast.GMS join_timeout="5000" join_retry_timeout="2000"
                         shun="true" print_local_addr="true" />
                         <pbcast.STATE_TRANSFER up_thread="true" down_thread="true" />
                         </Config>
                         </attribute>
                         </mbean>
                        
                         <!-- ==================================================================== -->
                         <!-- HA Session State Service for SFSB -->
                         <!-- ==================================================================== -->
                        
                         <mbean code="org.jboss.ha.hasessionstate.server.HASessionStateService"
                         name="jboss:service=HASessionState">
                         <depends>jboss:service=LocalPartition</depends>
                         <!-- Name of the partition to which the service is linked -->
                         <attribute name="PartitionName">LocalPartition</attribute>
                         <!-- JNDI name under which the service is bound -->
                         <attribute name="JndiName">/HASessionState/Local</attribute>
                         <!-- Max delay before cleaning unreclaimed state.
                         Defaults to 30*60*1000 => 30 minutes -->
                         <attribute name="BeanCleaningDelay">0</attribute>
                         </mbean>
                        
                         <!-- ==================================================================== -->
                         <!-- HA JNDI -->
                         <!-- ==================================================================== -->
                        
                         <mbean code="org.jboss.ha.jndi.HANamingService"
                         name="jboss:service=HAJNDI">
                         <depends>jboss:service=LocalPartition</depends>
                         <!-- Name of the partition to which the service is linked -->
                         <attribute name="PartitionName">LocalPartition</attribute>
                         <!-- bind address of HA JNDI RMI endpoint -->
                         <attribute name="BindAddress"></attribute>
                         <!-- RmiPort to be used by the HA-JNDI service
                         once bound. 0 => auto. -->
                         <attribute name="RmiPort">0</attribute>
                         <!-- Port on which the HA-JNDI stub is made available -->
                         <attribute name="Port">11100</attribute>
                         <!-- Backlog to be used for client-server RMI
                         invocations during JNDI queries -->
                         <attribute name="Backlog">50</attribute>
                        
                         <!-- Multicast Address and Group used for auto-discovery
                         <attribute name="AutoDiscoveryAddress">230.0.0.4</attribute>
                         <attribute name="AutoDiscoveryGroup">12102</attribute>-->
                        
                         <!-- IP Address to which should be bound: the Port, the RmiPort and
                         the AutoDiscovery multicast socket. -->
                         <!-- Client socket factory to be used for client-server
                         RMI invocations during JNDI queries -->
                         <!--attribute name="ClientSocketFactory">custom</attribute-->
                         <!-- Server socket factory to be used for client-server
                         RMI invocations during JNDI queries -->
                         <!--attribute name="ServerSocketFactory">custom</attribute-->
                         </mbean>
                        
                         <mbean code="org.jboss.invocation.jrmp.server.JRMPInvokerHA"
                         name="jboss:service=invoker,type=jrmpha">
                         <attribute name="ServerAddress"></attribute>
                         <!--
                         <attribute name="RMIObjectPort">0</attribute>
                         <attribute name="RMIClientSocketFactory">custom</attribute>
                         <attribute name="RMIServerSocketFactory">custom</attribute>
                         -->
                         </mbean>
                        
                         <!-- ==================================================================== -->
                         <!-- Distributed cache invalidation -->
                         <!-- ==================================================================== -->
                        
                         <mbean code="org.jboss.cache.invalidation.bridges.JGCacheInvalidationBridge"
                         name="jboss.cache:service=InvalidationBridge,type=JavaGroups">
                         <depends>jboss:service=LocalPartition</depends>
                         <depends>jboss.cache:service=InvalidationManager</depends>
                         <attribute name="InvalidationManager">jboss.cache:service=InvalidationManager</attribute>
                         <attribute name="PartitionName">LocalPartition</attribute>
                         <attribute name="BridgeName">LocalJGBridge</attribute>
                         </mbean>
                        
                        </server>
                        



                        • 9. Re: Non-multicast cluster problem
                          Todd Hough Newbie

                           

                          "toddh" wrote:
                          OK, that posting didn't work.

                          I just tried previewing it a few different ways and the forum keeps dropping parts of the config xml. Does this forum not support attachments?

                          The code snippets in my post on Friday didn't loose any formatting. You should be able to take cluster-service.xml and replace the UDP and PING elements with my TCP and TCPPING.

                          Just be sure and use the machine name instead of IP and try it without the bind_addr if you can. You might also try setting the bind address when you start JBoss using the -b command line switch.


                          • 10. Re: Non-multicast cluster problem
                            Tim Bauer Novice

                             

                            "tbauer" wrote:
                            Okay, that worked, but I AM NOT HAPPY about having to put a machine name....how stupid is that?? What could be more elemental than a static IP address?? Maybe when we get the documentation by March, this will be more explicitely documented....

                            <mbean code="org.jboss.ha.framework.server.ClusterPartition"
                            name="jboss:service=DefaultPartition">

                            <!-- Name of the partition being built -->
                            <attribute name="PartitionName">DefaultPartition</attribute>
                            <!-- Determine if deadlock detection is enabled -->
                            <attribute name="DeadlockDetection">False</attribute>
                            <!-- The JGroups protocol configuration -->
                            <attribute name="PartitionConfig">
                            <Config>
                            <TCP start_port="11800" />
                            <TCPPING initial_hosts="adsl-63-193-224-220.dsl.snfc21.pacbell.net[11800]"
                            port_range="5"
                            timeout="3000"
                            num_initial_members="5"
                            up_thread="true"
                            down_thread="true" />
                            <MERGE2
                            min_interval="5000"
                            max_interval="10000" />
                            <FD shun="true" up_thread="true" down_thread="true"
                            timeout="2500" max_tries="5" />
                            <VERIFY_SUSPECT timeout="3000" num_msgs="3"
                            up_thread="true" down_thread="true" />
                            <pbcast.NAKACK gc_lag="50" retransmit_timeout="300,600,1200,2400,4800"
                            up_thread="true" down_thread="true" />
                            <pbcast.STABLE desired_avg_gossip="20000"
                            up_thread="true" down_thread="true" />
                            <UNICAST timeout="5000" window_size="100" min_threshold="10"
                            down_thread="true" />
                            <FRAG frag_size="8192"
                            down_thread="true"
                            up_thread="true" />
                            <pbcast.GMS join_timeout="5000" join_retry_timeout="2000"
                            shun="true" print_local_addr="true" />
                            <pbcast.STATE_TRANSFER
                            up_thread="true" down_thread="true" />
                            </Config>
                            </attribute>
                            </mbean>

                            Also, HANamingService always barfs telling me that this address is not a multicast address...what's that all about...have tried several changes to the configuration but not luck...

                            <mbean code="org.jboss.ha.jndi.HANamingService"
                            name="jboss:service=HAJNDI">
                            <depends>jboss:service=DefaultPartition</depends>
                            <!-- Name of the partition to which the service is linked -->
                            <attribute name="PartitionName">DefaultPartition</attribute>
                            <!-- bind address of HA JNDI RMI endpoint -->
                            <attribute name="BindAddress">${jboss.bind.address}</attribute>
                            <!-- <attribute name="BindAddress">adsl-63-193-224-220.dsl.snfc21.pacbell.net</attribute> -->
                            <!-- RmiPort to be used by the HA-JNDI service
                            once bound. 0 => auto. -->
                            <attribute name="RmiPort">0</attribute>
                            <!-- Port on which the HA-JNDI stub is made available -->
                            <attribute name="Port">11100</attribute>
                            <!-- Backlog to be used for client-server RMI
                            invocations during JNDI queries -->
                            <attribute name="Backlog">50</attribute>

                            <!-- Multicast Address and Group used for auto-discovery -->
                            <!-- <attribute name="AutoDiscoveryAddress">63.193.224.220</attribute> -->
                            <attribute name="AutoDiscoveryAddress">230.0.0.4</attribute>
                            <attribute name="AutoDiscoveryGroup">12102</attribute>

                            <!-- IP Address to which should be bound: the Port, the RmiPort and
                            the AutoDiscovery multicast socket. -->
                            <!-- Client socket factory to be used for client-server
                            RMI invocations during JNDI queries -->
                            <!--attribute name="ClientSocketFactory">custom</attribute-->
                            <!-- Server socket factory to be used for client-server
                            RMI invocations during JNDI queries -->
                            <!--attribute name="ServerSocketFactory">custom</attribute-->
                            </mbean>