4 Replies Latest reply on Jul 8, 2004 3:39 PM by Miguel Moutinho

    Suddenly a strange Exception

    morenito9000 Newbie

      Hi all,
      I have used JBoss with no problems for several days, but now
      I suddenly get this strange exception when I restart JBoss
      (the exception is cyclicly thrown):

      DEBUG [org.javagroups.DefaultPartition] [Wed Jun 16 10:48:53 CEST 2004] [ERROR] UDP.handleIncomingUdpPacket(): exception=java.io.StreamCorruptedException
      at java.io.ObjectInputStream$BlockDataInputStream.readBlockHeader(ObjectInputStream.java:2347)
      at java.io.ObjectInputStream$BlockDataInputStream.refill(ObjectInputStream.java:2380)
      at java.io.ObjectInputStream$BlockDataInputStream.read(ObjectInputStream.java:2539)
      at java.io.ObjectInputStream$BlockDataInputStream.readFully(ObjectInputStream.java:2579)
      at java.io.ObjectInputStream.readFully(ObjectInputStream.java:961)
      at org.jgroups.protocols.UdpHeader.readExternal(UdpHeader.java:50)
      at org.jgroups.util.Marshaller.read(Marshaller.java:77)
      at org.jgroups.Message.readExternal(Message.java:352)
      at org.jgroups.protocols.UDP.handleIncomingUdpPacket(UDP.java:527)
      at org.jgroups.protocols.UDP.run(UDP.java:210)
      at java.lang.Thread.run(Thread.java:534)

      Before restarting JBoss I deleted my application's EAR file
      (and a JAR file I put in directory) in order
      to start from a "clean" configuration, but nothing
      changed (I got the exception again).

      Any help is very appreciated,
      Moreno

        • 1. Re: Suddenly a strange Exception
          Martin Uhlig Newbie

          Hi,

          we are seeing the same exception with JBoss 3.2.4RC2. With JBoss 3.2.4 it seems to have changed to

          2004-06-15 12:50:04,168 WARN [org.jgroups.protocols.UDP] discarded message from different group (). Sender was host:41639 (additional data: 19 bytes)

          Since we have two clusters running, one with 3.2.4RC2 and the other with 3.2.4, my best bet is that they receive each others messages, but 3.2.4 handles it more gracefully.

          Could anyone confirm this, or otherwise point to a different solution?

          Cheers
          Martin

          • 2. Re: Suddenly a strange Exception
            morenito9000 Newbie

            The strange thing is that I haven't a cluster scenario:
            my JBoss runs on a single machine and it has never
            thrown a similar exception before now.

            Many thanks
            Moreno

            • 3. Re: Suddenly a strange Exception
              octopus Newbie

              just upgraded from 3.2.3 to 3.2.4 and start receiving the same error.

              11:50:39,125 WARN [UDP] discarded message from different group (TreeCache-Cluster). Sender was 192.168.2.3:3678
              11:50:44,421 WARN [UDP] discarded message from different group (DefaultPartition). Sender was 192.168.2.3:3610 (addition
              al data: 16 bytes)
              11:50:56,812 WARN [UDP] discarded message from different group (TreeCache-Cluster). Sender was 192.168.2.3:3678
              11:50:57,453 WARN [UDP] discarded message from different group (DefaultPartition). Sender was 192.168.2.3:3610 (addition
              al data: 16 bytes)
              11:51:12,234 WARN [UDP] discarded message from different group (TreeCache-Cluster). Sender was 192.168.2.3:3678
              11:51:19,062 WARN [UDP] discarded message from different group (DefaultPartition). Sender was 192.168.2.3:3610 (addition
              al data: 16 bytes)
              11:51:30,046 WARN [UDP] discarded message from different group (TreeCache-Cluster). Sender was 192.168.2.3:3678
              11:51:36,359 WARN [UDP] discarded message from different group (DefaultPartition). Sender was 192.168.2.3:3610 (addition
              al data: 16 bytes)

              this is a single cluster node running on 192.168.2.3 with jboss cache installed.

              the same config worked fine on 3.2.3

              • 4. Re: Suddenly a strange Exception
                Miguel Moutinho Newbie

                I'm having this situation whenever I try to send messages through JChannel inside my beans using JBoss 3.2.4RC2 and 3.2.5.
                With 3.2.3 no problem. I'd like to know why this happens and if anyone could tell me how to avoid it, I'd be glad!