0 Replies Latest reply on Nov 17, 2006 6:38 AM by Daniel Braunsdorf

    Strange cluster error message resulting in an OutOfMemoryErr

    Daniel Braunsdorf Newbie

      Hi @all,

      we have experienced a strange problem with our JBoss cluster this morning.

      2006-11-17 08:02:59,281 WARN [org.jgroups.protocols.FD] I was suspected, but will not remove myself from membership (waiting for EXIT message)
      
      2006-11-17 08:02:59,738 WARN [org.jgroups.protocols.FD] I was suspected, but will not remove myself from membership (waiting for EXIT message)
      
      2006-11-17 08:03:08,220 WARN [org.jgroups.protocols.pbcast.CoordGmsImpl] I am the coord and I'm being am suspected -- will probably leave shortly
      
      2006-11-17 08:03:08,228 INFO [org.jboss.ha.framework.interfaces.HAPartition.lifecycle.DefaultPartition] Suspected member: t-mw-as2:32833 (additional data: 15 bytes)
      
      2006-11-17 08:03:08,235 WARN [org.jgroups.protocols.pbcast.GMS] checkSelfInclusion() failed, t-mw-as2:32833 (additional data: 15 bytes) is not a member of view [172.16.0.9:32831 (additional data: 15 bytes)|4] [172.16.0.9:32831 (additional data: 15 bytes)]; discarding view
      
      2006-11-17 08:03:08,235 WARN [org.jgroups.protocols.pbcast.GMS] I (t-mw-as2:32833 (additional data: 15 bytes)) am being shunned, will leave and rejoin group (prev_members are [t-mw-as2:32833 (additional data: 15 bytes) 172.16.0.9:32825 (additional data: 15 bytes) 172.16.0.9:32831 (additional data: 15 bytes) ])
      
      ?


      Only a few time later the following happened:

      2006-11-17 08:06:14,646 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/web].[IstPortalEJB]] Servlet.service() for servlet IstPortalEJB threw exception: java.lang.OutOfMemoryError


      I wonder if the OutOfMemoryError is a result of the ongoing problems with the cluster, but have to mention that the cluster was running fine over about three months.

      As any of you experieenced any of these problems? What may be the source of the problem with the cluster? Network problems? Some coding errors? Or ...?

      Thanks in advance!