1 Reply Latest reply on Dec 6, 2006 10:11 AM by Brian Stansberry

    ERROR [[jsp]] Servlet.service() for servlet jsp threw except

    Rajesh Newbie

      Hi,

      i have a cluster implemented with three nodes and Running fine with around 30 applications deployed on Sun OS.

      now a days, i can see one instance is causing problem and applications are not accesible when the request went to particular node.

      I see the below stack trace in server logs.

      INFO | jvm 1 | 2006/12/06 12:14:48 | 12:14:48,878 INFO [WebappClassLoader] Illegal access: this web application instanc
      e has been stopped already. Could not load org.jboss.net.protocol.jar.Handler. The eventual following stack trace is caused
      by an error thrown for debugging purposes as well as to attempt to terminate the thread which caused the illegal access, and
      has no functional impact.
      INFO | jvm 1 | 2006/12/06 12:14:48 | 12:14:48,878 ERROR [[jsp]] Servlet.service() for servlet jsp threw exception
      INFO | jvm 1 | 2006/12/06 12:14:48 | java.lang.ThreadDeath
      INFO | jvm 1 | 2006/12/06 12:14:48 | at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.j
      ava:1221)
      INFO | jvm 1 | 2006/12/06 12:14:48 | at java.lang.ClassLoader.loadClass(ClassLoader.java:299)
      INFO | jvm 1 | 2006/12/06 12:14:48 | at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
      INFO | jvm 1 | 2006/12/06 12:14:48 | at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
      INFO | jvm 1 | 2006/12/06 12:14:48 | at java.lang.Class.forName0(Native Method)
      INFO | jvm 1 | 2006/12/06 12:14:48 | at java.lang.Class.forName(Class.java:164)


      The remaining two nodes in the same cluster will process requests during the time....

      The affected node only active after restart...

      Can any one help me, why i am getting this "java.lang.ThreadDeath" exception and how to resolve this.


      Thanks in advance,
      -Rajesh Gajula

        • 1. Re: ERROR [[jsp]] Servlet.service() for servlet jsp threw ex
          Brian Stansberry Master

          This error happens when somehow your app is trying to load a class, and the classloader being asked to do it is a stale one left around from an earlier deployment of the webapp. Perhaps you redeployed the app but something is holding a ref to a class loaded from the previous deployment.

          A quick solution is probably to restart the server.

          Sorry I can't provide more details than this, e.g. how to find exactly what the cause is. Suggest you post on the tomcat forum here at JBoss, or on the tomcat-user mailing list. Be sure to mention what release you are running, as that *could be* very relevant.