1 Reply Latest reply on Jan 12, 2009 11:03 PM by chicken chicken

    some errors occur when update war file in farm folder

    chicken chicken Newbie

      Dear all

      I have twos nodes that form a cluster.
      When I use ant command to update my application (a war file in the farm folder) ==> my application undeploy, redeploy successfully. after my application redeploy successfully I get some error:

      -------------------------------------
      2009-01-13 11:05:29,972 DEBUG [org.jboss.web.tomcat.filters.ReplyHeaderFilter] Adding header name: X-Powered-By='Servlet 2.4; JBoss-4.2.3.GA (build: SVNTag=JBoss_4_2_3_GA date=200807181417)/JBossWeb-2.0'
      2009-01-13 11:05:29,976 INFO [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/web-console]] Marking servlet HTTP Invocation as unavailable
      2009-01-13 11:05:29,977 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/web-console]] Error loading WebappClassLoader

      delegate: false

      repositories:

      /WEB-INF/classes/

      ----------> Parent Classloader:

      java.net.FactoryURLClassLoader@9dc1bb

      org.jboss.console.remote.InvokerServlet
      java.lang.ClassNotFoundException: org.jboss.console.remote.InvokerServlet
      at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1358)
      at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1204)
      at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1083)
      at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:981)
      at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:4071)
      at org.apache.catalina.core.StandardContext.start(StandardContext.java:4375)
      at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:790)
      at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:770)
      at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:553)
      -----------------------------------
      2009-01-13 11:05:29,996 INFO [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/web-console]] Marking servlet Clear Monitor Alerts as unavailable
      2009-01-13 11:05:29,996 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/web-console]] Error loading WebappClassLoader

      delegate: false

      repositories:

      /WEB-INF/classes/

      ----------> Parent Classloader:

      java.net.FactoryURLClassLoader@9dc1bb

      org.jboss.console.plugins.monitor.ClearMonitorAlertsServlet
      java.lang.ClassNotFoundException: org.jboss.console.plugins.monitor.ClearMonitorAlertsServlet
      at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1358)
      at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1204)
      at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1083)
      at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:981)
      at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:4071)
      at org.apache.catalina.core.StandardContext.start(StandardContext.java:4375)
      at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:790)
      at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:770)
      at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:553)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

      -------------------------------
      2009-01-13 11:05:30,229 INFO [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/web-console]] Marking servlet MonitorsFolder as unavailable
      2009-01-13 11:05:30,229 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/web-console]] Error loading WebappClassLoader

      delegate: false

      repositories:

      /WEB-INF/classes/

      ----------> Parent Classloader:

      java.net.FactoryURLClassLoader@9dc1bb

      org.jboss.console.plugins.helpers.ServletPluginHelper
      java.lang.ClassNotFoundException: org.jboss.console.plugins.helpers.ServletPluginHelper
      at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1358)
      at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1204)
      at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1083)
      at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:981)
      at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:4071)
      -----------------------
      at org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.run(AbstractDeploymentScanner.java:225)
      2009-01-13 11:05:30,405 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/web-console]] Servlet /web-console threw load() exception
      java.lang.ClassNotFoundException: org.jboss.console.plugins.monitor.AcknowledgeActiveAlarmsServlet
      at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1358)
      at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1204)
      at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1083)
      at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:981)
      at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:4071)
      at org.apache.catalina.core.StandardContext.start(StandardContext.java:4375)
      at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:790)
      at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:770)
      .....................
      then my application is reloaded automatically
      and I get some error infor in DEBUG:

      ------------------
      2009-01-13 11:05:59,893 DEBUG [org.jboss.mq.il.uil2.SocketManager] End WriteTask.run Thread[UIL2.SocketManager.WriteTask#34 client=192.168.1.15:48407,5,JBossMQ Server Threads]
      2009-01-13 11:05:59,894 DEBUG [org.jboss.mq.il.uil2.ServerSocketManagerHandler] Exiting on IOE
      java.io.InterruptedIOException: Operation interrupted
      at java.net.SocketInputStream.socketRead0(Native Method)
      at java.net.SocketInputStream.read(Unknown Source)
      at java.io.BufferedInputStream.fill(Unknown Source)
      at java.io.BufferedInputStream.read(Unknown Source)
      at org.jboss.util.stream.NotifyingBufferedInputStream.read(NotifyingBufferedInputStream.java:79)
      at java.io.ObjectInputStream$PeekInputStream.peek(Unknown Source)
      at java.io.ObjectInputStream$BlockDataInputStream.readBlockHeader(Unknown Source)
      ------------------
      2009-01-13 11:05:59,901 DEBUG [org.jboss.mq.il.uil2.ServerSocketManagerHandler] Exiting on IOE
      java.io.InterruptedIOException: Operation interrupted
      at java.net.SocketInputStream.socketRead0(Native Method)
      at java.net.SocketInputStream.read(Unknown Source)
      at java.io.BufferedInputStream.fill(Unknown Source)
      at java.io.BufferedInputStream.read(Unknown Source)
      at org.jboss.util.stream.NotifyingBufferedInputStream.read(NotifyingBufferedInputStream.java:79)
      at java.io.ObjectInputStream$PeekInputStream.peek(Unknown Source)

      at the end one node doesn't work and my application is not available for accessibility although other node works well

      Could any one give me some suggestions to solve this problem?

      Thanks in advance!