3 Replies Latest reply on Aug 19, 2003 9:03 AM by Adrian Brock

    Jboss Siebel Integration (Urgent)

    arpanabansal Newbie

      I have Siebel_JCA.rar file and *_ds.xml file .
      But on deploying it in jboss .. it throws an error of NoTYETINSTALLED .

      Can anyone suggest me the probable reason .
      follwoing is the *ds.xml file.
      <?xml version="1.0" encoding="UTF-8"?>

      <connection-factories>

      <no-tx-connection-factory>
      <jndi-name>eis/SiebelResourceAdapterJNDIName</jndi-name>
      <adapter-display-name>Siebel Adapter</adapter-display-name>
      <min-pool-size>1</min-pool-size>
      <max-pool-size>10</max-pool-size>
      <blocking-timeout-millis>500</blocking-timeout-millis>
      <idle-timeout-minutes>10</idle-timeout-minutes>
      </no-tx-connection-factory>
      </connection-factories>

      Are these settings correct ..or there is something missing.

      Thanks in advance,
      Arpana

        • 1. Re: Jboss Siebel Integration (Urgent)
          Adrian Brock Master

          What did you call the file.
          It must end in -ds.xml

          Post the full message and any other about the
          deployment.

          You might get more info from log/server.log with
          debug enabled.

          Regards,
          Adrian

          • 2. Re: Jboss Siebel Integration (Urgent)
            arpanabansal Newbie

            Okie.. will explain in detail..

            I am using Jboss 4.0 and need to integrate Siebel with Jboss.
            For implementing,
            I copied the Siebel_JCA.rar file to the \server\default\deploy folder .
            And also copied Siebel_JCA-ds.xml file in the same folder.


            While deployment the jboss console throws the following error :::
            { objectName: jboss.deployment:name=file%3a/C%3a/jboss_4.0.0DR2/server/default/deploy/Siebel_JCA-ds.xml,service=DeploymentInfo
            state: NOTYETINSTALLED
            I am waiting for:
            jboss.deployment:service=DeploymentInfo,name=Siebel Adapter state: NOTYETINSTALLED
            } org.jboss.system.ServiceContext@ea533cbb,


            The server.log is also displaying the same error message.

            Actually I had weblogic-ra.xml, so converted it into Siebel_JCA-ds.xml.
            Following is the Siebel_JCA-ds.xml file ::::
            <?xml version="1.0" encoding="UTF-8"?>
            <connection-factories>
            <no-tx-connection-factory>
            <jndi-name>eis/SiebelResourceAdapterJNDIName</jndi-name>
            <adapter-display-name>Siebel Adapter</adapter-display-name>
            <security-domain>SiebelRealm</security-domain>
            <min-pool-size>1</min-pool-size>
            <max-pool-size>10</max-pool-size>
            <blocking-timeout-millis>500</blocking-timeout-millis>
            <idle-timeout-minutes>10</idle-timeout-minutes>
            </no-tx-connection-factory>
            </connection-factories>


            Can you suggest a probable reason for above mentioned error.

            Regards,
            Arpana

            • 3. Re: Jboss Siebel Integration (Urgent)
              Adrian Brock Master

              What is the display-name in the ra.xml?
              It should match the adapter-display-name in your -ds.xml

              Regards,
              Adrian