0 Replies Latest reply on Jan 10, 2006 12:08 AM by Prashant Tiwari

    not deploying postgress-ds.xml.......

    Prashant Tiwari Newbie

      Hi,

      I m using JBoss4.0.3 & Eclipse 3.2 with JDK 1.4.2. I ve created A database in Postgres8.0 named database1 & contents in my "postgress-ds.xml" file is
      ======

      <local-tx-datasource>
      <jndi-name>ProgressDS</jndi-name> <connection-url>jdbc:postgresql://localhost:5432/database1</connection-url>
      <driver-class>org.postgresql.Driver</driver-class>
      <user-name>local</user-name>
      local

      <type-mapping>PostgreSQL 8.0</type-mapping>

      </local-tx-datasource>

      ========

      I copied this file into server/default/deploy directory in JBoss installation Directory. & when I start jboss server in Eclipse I get following error mesage:--

      ======
      10:18:34,765 INFO [Server] Starting JBoss (MX MicroKernel)...
      10:18:34,812 INFO [Server] Release ID: JBoss [Zion] 4.0.3 (build: CVSTag=JBoss_4_0_3 date=200510042341)
      10:18:34,828 INFO [Server] Home Dir: C:\local\jboss-4.0.3
      10:18:34,828 INFO [Server] Home URL: file:/C:/local/jboss-4.0.3/
      10:18:34,828 INFO [Server] Patch URL: null
      10:18:34,828 INFO [Server] Server Name: default
      10:18:34,828 INFO [Server] Server Home Dir: C:\local\jboss-4.0.3\server\default
      10:18:34,828 INFO [Server] Server Home URL: file:/C:/local/jboss-4.0.3/server/default/
      10:18:34,828 INFO [Server] Server Temp Dir: C:\local\jboss-4.0.3\server\default\tmp
      10:18:34,828 INFO [Server] Root Deployment Filename: jboss-service.xml
      10:18:35,921 INFO [ServerInfo] Java version: 1.4.2_09,Sun Microsystems Inc.
      10:18:35,921 INFO [ServerInfo] Java VM: Java HotSpot(TM) Client VM 1.4.2_09-b05,Sun Microsystems Inc.
      10:18:35,921 INFO [ServerInfo] OS-System: Windows 2000 5.0,x86
      10:18:37,171 INFO [Server] Core system initialized
      10:18:38,687 INFO [Log4jService$URLWatchTimerTask] Configuring from URL: resource:log4j.xml
      10:18:43,593 INFO [NamingService] Started jndi bootstrap jnpPort=1099, rmiPort=1098, backlog=50, bindAddress=/0.0.0.0, Client SocketFactory=null, Server SocketFactory=org.jboss.net.sockets.DefaultSocketFactory@ad093076
      10:18:46,046 INFO [Embedded] Catalina naming disabled
      10:18:48,437 INFO [Http11Protocol] Initializing Coyote HTTP/1.1 on http-0.0.0.0-8080
      10:18:48,453 INFO [Catalina] Initialization processed in 1625 ms
      10:18:48,468 INFO [StandardService] Starting service jboss.web
      10:18:48,500 INFO [StandardEngine] Starting Servlet Engine: Apache Tomcat/5.5
      10:18:48,703 INFO [StandardHost] XML validation disabled
      10:18:48,828 INFO [Catalina] Server startup in 375 ms
      10:18:49,421 INFO [TomcatDeployer] deploy, ctxPath=/, warUrl=.../deploy/jbossweb-tomcat55.sar/ROOT.war/
      10:18:51,109 INFO [WebappLoader] Dual registration of jndi stream handler: factory already defined
      10:18:53,015 INFO [TomcatDeployer] deploy, ctxPath=/jmx-console, warUrl=.../deploy/jmx-console.war/
      10:18:53,437 ERROR [URLDeploymentScanner] Incomplete Deployment listing:

      --- Packages waiting for a deployer ---
      org.jboss.deployment.DeploymentInfo@3aab164e { url=file:/C:/local/jboss-4.0.3/server/default/deploy/progress-ds.xml }
      deployer: null
      status: null
      state: INIT_WAITING_DEPLOYER
      watch: file:/C:/local/jboss-4.0.3/server/default/deploy/progress-ds.xml
      altDD: null
      lastDeployed: 1136868532703
      lastModified: 1136868532703
      mbeans:

      --- Incompletely deployed packages ---
      org.jboss.deployment.DeploymentInfo@3aab164e { url=file:/C:/local/jboss-4.0.3/server/default/deploy/progress-ds.xml }
      deployer: null
      status: null
      state: INIT_WAITING_DEPLOYER
      watch: file:/C:/local/jboss-4.0.3/server/default/deploy/progress-ds.xml
      altDD: null
      lastDeployed: 1136868532703
      lastModified: 1136868532703
      mbeans:
      10:18:53,578 INFO [Http11Protocol] Starting Coyote HTTP/1.1 on http-0.0.0.0-8080
      10:18:54,328 INFO [ChannelSocket] JK: ajp13 listening on /0.0.0.0:8009
      10:18:54,390 INFO [JkMain] Jk running ID=0 time=0/250 config=null
      10:18:54,437 INFO [Server] JBoss (MX MicroKernel) [4.0.3 (build: CVSTag=JBoss_4_0_3 date=200510042341)] Started in 19s:594ms

      =======


      Why I m getting message like
      "INIT_WAITING_DEPLOYER".........

      & the postgres-ds.xml file not get deployed.

      Pls Help me......

      Thanx in advance.....
      Prash