4 Replies Latest reply on Sep 11, 2007 8:16 PM by Joe Greene

    Richfaces components not rendering properly - can't find sty

    Joe Greene Novice

      Hello -
      We are working on creating RF components in our jsps. Our IDE is Red Hat Developer Studio, and we are using Seam, OC4J, Richfaces, ajax4jsf, and JSPs instead of facelets (don?t ask!). We can?t get any RF component to render on our page, although the Red Hat IDE displays the component just fine underneath the code in the graphical area. We started with several components, then just made a simple example with a <rich:panel for testing. Here?s the markup I use for the test rich panel in the jsp:

      <rich:panel>
       <f:facet name="header">
       <h:outputText value="Test Panel"/>
       </f:facet>
       <f:verbatim>testing...</f:verbatim>
      </rich:panel>
      


      When I load the page, this is the markup for the panel component that gets generated:
      <div class="dr-pnl rich-panel " id="welcomeForm:j_id___jsp_tag_ctru80"><div class="dr-pnl-h rich-panel-header " id="welcomeForm:j_id___jsp_tag_ctru80_header">Test Panel</div><div class="dr-pnl-b rich-panel-body " id="welcomeForm:j_id___jsp_tag_ctru80_body">testing...</div></div>



      And here?s the stylesheet and js markup that gets generated in the section of the page by Richfaces:

      <link rel='stylesheet' type='text/css' href='/jmat/a4j_3_1_0-SNAPSHOTcss/toolBar.xcss/DATB/eAHTF-LfBgABygEH.seam' /><link rel='stylesheet' type='text/css' href='/jmat/a4j_3_1_0-SNAPSHOTcss/dropdownmenu.xcss/DATB/eAHTF-LfBgABygEH.seam' /><link rel='stylesheet' type='text/css' href='/jmat/a4j_3_1_0-SNAPSHOTcss/menucomponents.xcss/DATB/eAHTF-LfBgABygEH.seam' /><link rel='stylesheet' type='text/css' href='/jmat/a4j_3_1_0-SNAPSHOTcss/panel.xcss/DATB/eAHTF-LfBgABygEH.seam' /><link rel='stylesheet' type='text/css' href='/jmat/a4j_3_1_0-SNAPSHOTorg/richfaces/renderkit/html/css/modalPanel.xcss/DATB/eAHTF-LfBgABygEH.seam' /><script type='text/javascript' src='/jmat/a4j_3_1_0-SNAPSHOTorg.ajax4jsf.javascript.PrototypeScript.seam'></script><script type='text/javascript' src='/jmat/a4j_3_1_0-SNAPSHOTorg.ajax4jsf.javascript.AjaxScript.seam'></script><script type='text/javascript' src='/jmat/a4j_3_1_0-SNAPSHOTscripts/menu.js.seam'></script><script type='text/javascript' src='/jmat/a4j_3_1_0-SNAPSHOTorg/richfaces/renderkit/html/scripts/utils.js.seam'></script><script type='text/javascript' src='/jmat/a4j_3_1_0-SNAPSHOTorg/ajax4jsf/javascript/scripts/form.js.seam'></script><script type='text/javascript' src='/jmat/a4j_3_1_0-SNAPSHOTorg/richfaces/renderkit/html/scripts/form.js.seam'></script><script type='text/javascript' src='/jmat/a4j_3_1_0-SNAPSHOTorg/richfaces/renderkit/html/scripts/modalPanel.js.seam'></script><script type='text/javascript' src='/jmat/a4j_3_1_0-SNAPSHOTorg/richfaces/renderkit/html/scripts/modalPanelBorders.js.seam'></script><script type='text/javascript' src='/jmat/a4j_3_1_0-SNAPSHOTorg/richfaces/renderkit/html/scripts/browser_info.js.seam'></script>
      


      The only thing that renders is the text within the component - the styles are not applied, so it doesn't look like a panel - just the text is shown.

      If the stylesheet markup and component markup are both generated, why would the components not render? Maybe the page can?t find the stylesheets? But why? These are the stylesheets that Richfaces generates.

      Please, any help on this would be greatly appreciated. I hope it is something easy that I?m forgetting or just not doing.