0 Replies Latest reply on Aug 29, 2002 4:00 PM by Przemys³aw Ciesielski

    PetStore 1.3.1 and JBoss 3.0.0

    Przemys³aw Ciesielski Newbie

      hello,

      I'm new to JBoss and J2ee.

      I've installed JBoss 3.0.0 on FreeBSD to /usr/local/jboss

      I'm trying to run PetStore, but without any success.
      I've set up:
      $JAVA_HOME=/usr/local/jdk1.3.1
      $J2EE_HOME=/usr/local/jboss
      $ANT_HOME=/usr/local/ant

      now i cd to PetStore do ./setup.sh:
      [21:04:13](pck)@(rephosphorization)[/usr/local/jboss/appz/petstore1.3.1]$ ./setup.sh
      /usr/local/jboss/lib/j2ee.jar:./src/lib/ant/lib/ant.jar:./src/lib/ant/lib/parser.jar:./src/lib/ant/lib/jaxp.jar:/usr/local/jdk1.3.1/lib/tools.jar
      Buildfile: setup.xml

      init:

      help:

      create_jms_queues:
      [echo] Creating JMS Queues ....
      [java] Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/enterprise/tools/admin/AdminTool
      [java] Java Result: 1
      [java] Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/enterprise/tools/admin/AdminTool
      [java] Java Result: 1
      [java] Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/enterprise/tools/admin/AdminTool
      [java] Java Result: 1
      [java] Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/enterprise/tools/admin/AdminTool
      [java] Java Result: 1
      [java] Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/enterprise/tools/admin/AdminTool
      [java] Java Result: 1
      [java] Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/enterprise/tools/admin/AdminTool
      [java] Java Result: 1
      [java] Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/enterprise/tools/admin/AdminTool
      [java] Java Result: 1
      [java] Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/enterprise/tools/admin/AdminTool
      [java] Java Result: 1
      [java] Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/enterprise/tools/admin/AdminTool
      [java] Java Result: 1
      [java] Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/enterprise/tools/admin/AdminTool
      [java] Java Result: 1
      [java] Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/enterprise/tools/admin/AdminTool
      [java] Java Result: 1
      [java] Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/enterprise/tools/admin/AdminTool
      [java] Java Result: 1
      [java] Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/enterprise/tools/admin/AdminTool
      [java] Java Result: 1
      [java] Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/enterprise/tools/admin/AdminTool
      [java] Java Result: 1

      create_users:
      [echo] Creating users ....
      [java] Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/enterprise/tools/admin/RealmTool
      [java] Java Result: 1
      [java] Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/enterprise/tools/admin/RealmTool
      [java] Java Result: 1
      [java] Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/enterprise/tools/admin/RealmTool
      [java] Java Result: 1

      create_petstore_db:
      [java] Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/enterprise/tools/admin/AdminTool
      [java] Java Result: 1

      create_supplier_db:
      [java] Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/enterprise/tools/admin/AdminTool
      [java] Java Result: 1

      create_opc_db:
      [java] Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/enterprise/tools/admin/AdminTool
      [java] Java Result: 1

      core:
      [echo] The J2EE SDK is now successfully configured to run the petstore application. Please restart cloudscape and the j2ee servers, and deploy all the ear files. You can do this by issuing the following commands:
      [echo] change directory to j2sdkee1.3/bin; start RI and Cloudscape in separate windows
      [echo] cloudscape -start
      [echo] j2ee -verbose
      [echo] change directory to petstore1.3.1 to deploy the EAR files
      [echo] setup.bat deploy (or on Unix, setup.sh deploy)

      BUILD SUCCESSFUL

      Total time: 6 seconds
      [21:08:21](pck)@(rephosphorization)[/usr/local/jboss/appz/petstore1.3.1]$


      then i restart JBoss and do:
      [21:08:21](pck)@(rephosphorization)[/usr/local/jboss/appz/petstore1.3.1]$ ./setup.sh deploy
      /usr/local/jboss/lib/j2ee.jar:./src/lib/ant/lib/ant.jar:./src/lib/ant/lib/parser.jar:./src/lib/ant/lib/jaxp.jar:/usr/local/jdk1.3.1/lib/tools.jar
      Buildfile: setup.xml

      init:

      deploy:
      [echo] Deploying ears ....
      [java] Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/enterprise/tools/deployment/main/Main
      [java] Java Result: 1
      [java] Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/enterprise/tools/deployment/main/Main
      [java] Java Result: 1
      [java] Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/enterprise/tools/deployment/main/Main
      [java] Java Result: 1
      [java] Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/enterprise/tools/deployment/main/Main
      [java] Java Result: 1
      [echo] The petstore application is now installed.
      [echo] Please restart your cloudscape database and the J2EE server, and then point your browser to http://rephosphorization:8080/petstore to access petstore.

      BUILD SUCCESSFUL

      Total time: 1 second
      [21:09:29](pck)@(rephosphorization)[/usr/local/jboss/appz/petstore1.3.1]$

      And again I'm restaring JBoss, then:

      [21:12:52](pck)@(rephosphorization)[/usr/ports/www/lynx]$ lynx --dump http://rephosphorization:8080/petstore

      Apache Tomcat/4.0.3 - HTTP Status 500 - No Context configured to process this
      request
      _________________________________________________________________

      type Status report

      message No Context configured to process this request

      description The server encountered an internal error (No Context
      configured to process this request) that prevented it from fulfilling
      this request.
      _________________________________________________________________


      Why? What i've forgot about?

      TIA!

      --
      pck.