2 Replies Latest reply on Sep 12, 2007 11:00 AM by Marcelo Krebber

    background color of customs skins not being displayed

    Marcelo Krebber Newbie

      i have posted this problem somewhere else in the forum already, and since RC6 had still this problem, im hoping with GA is the problem solved. we have acustom skin in our application for gloabl background panel color for ex. and when using a <rich:panel> or <rich:simpleTogglePanel> until RC3 the background was being displayed correctly. aftrewards it looks like the color settings are just ignored and the background will be always white.

      any idea? thanks.
      marcelo

        • 1. Re: background color of customs skins not being displayed
          Sergey Smirnov Master

          Marcelo, GA is almost the same that RC6. As soon as we had no info about the problem you met, the problem might not to disappear by itself.

          I am not sure I already understand how to reproduce of what you have on your side.

          Could you provide more details or may be the test application where the problem is reproduced.

          • 2. Re: background color of customs skins not being displayed
            Marcelo Krebber Newbie

            yes - this is a sample skin for configuring our app:

            MYSKIN.skin.properties:

            #Colors
            headerBackgroundColor=#6598CB
            headerGradientColor=#6598CB
            headerTextColor=#FFFFFF
            headerWeightFont=bold
            
            generalBackgroundColor=#FFFFFF
            generalTextColor=#EEEEEE
            generalSizeFont=11px
            generalFamilyFont=Arial, Verdana, sans-serif
            
            controlTextColor=#000000
            controlBackgroundColor=red
            additionalBackgroundColor=#336699
            
            shadowBackgroundColor=#000000
            shadowOpacity=1
            
            panelBorderColor=#C0C0C0
            subBorderColor=#6598CB
            ....
            


            in web.xml we have:

            <context-param>
             <param-name>org.ajax4jsf.SKIN</param-name>
             <param-value>MYSKIN</param-value>
             </context-param>
            


            now, headerBackgroundColor=#6598CB is being ignored. it apperas it uses always generalBackgroundColor=#FFFFFF . again, up to RC3 this was still working correctly for <rich:panle> and <rich:simpleTogglePanel>

            greetings. marcelo