0 Replies Latest reply on Aug 3, 2003 11:58 AM by rabihyazbeck

    commons-logging on JBoss not working

    rabihyazbeck Newbie

      I am porting a web application from Tomcat to JBoss.
      This application used commons-logging on top of log4j to do its logging. I didnt change anything in the logging configuration and the location of the propreties files, but it is not working.

      commons-logging.properties and log4j.properties are in app.ear/webapp.ear/WEB-INF/

      (i enven tried to change their locations to default/lib and other places and still it is not working)

      with the following entries:

      commons-logging.properties:

      org.apache.commons.logging.Log=org.apache.commons.logging.impl.Log4JLogger

      log4j.properties:

      log4j.rootLogger=DEBUG, stdout, rolling

      log4j.appender.stdout=org.apache.log4j.ConsoleAppender

      log4j.appender.stdout.layout=org.apache.log4j.PatternLayout

      log4j.appender.stdout.layout.ConversionPattern=%5p [%t] (%F:%L) - %m%n

      log4j.appender.rolling=org.apache.log4j.RollingFileAppender

      log4j.appender.rolling.File=D:\\cbclog.txt

      log4j.appender.rolling.MaxFileSize=200KB

      log4j.appender.rolling.MaxBackupIndex=10

      log4j.appender.rolling.layout=org.apache.log4j.PatternLayout
      log4j.appender.rolling.layout.ConversionPattern=%d{ABSOLUTE} - %p %c - %m%n





      Do I need to do make any changes in the configuration and/or the location of the properties files, or any other JBoss-specific configuration?

      Thank you in advance.. R

      Rabih