3 Replies Latest reply on Apr 17, 2004 8:45 PM by Jon Barnett

    jboss on redhat 9

    stm23 Newbie

      hi, i'm trying to install & configure jboss3.2.3 on redhat 9.
      after logging in as root, & executing run.sh i get a whole lot of error messages, all of which contain the line "Failed to find META-INF/jboss-service.xml. for example:

      18:20:33,308 ERROR [MainDeployer] Could not initialise deloyment: file:/usr/local/jboss/server/default/deploy/jmx-invoker-adaptor-server.sar/
      org.jboss.deployment.DeploymentException: Failed to find META-INF/jboss-service.xml

      &

      18:20:30,911 ERROR [MainDeployer] Could not initialise deloyment: file:/usr/local/jboss/server/default/deploy/snmp-adaptor.sar/
      org.jboss.deployment.DeploymentException: Failed to find META-INF/jboss-service.xml

      does any1 know what i can do to successfully run jboss? - i'd really appreciate any help u can offer me
      cheers, sam

        • 1. Re: jboss on redhat 9
          Luigi Fonti Newbie

          It seems the file jboss-service.xml is really missing. Can you check if the file is present in directory:
          /usr/local/jboss/server/default/deploy/jmx-invoker-adaptor-server.sar/META-INF ?
          It should be there, otherwise jboss was not completely installed.

          • 2. Re: jboss on redhat 9
            stm23 Newbie

            hi, thanx for yr reply, i have downloaded it a couple of times, & that xml file is always there. did u have to specify any classpath options or modify the run.conf file? or did it work straitaway after executing run.sh? perhaps it depends on some other programs being installed. any ideas? - appreciate yr help
            cheers, sam

            • 3. Re: jboss on redhat 9
              Jon Barnett Master

              Did you execute run.sh from the JBOSS_HOME/bin directory? Also make sure that JAVA_HOME is defined to point to your Java root directory. You can do that in JBOSS_HOME/bin/run.conf.

              I have the following line in my Slackware 9.1 system:

              JAVA_HOME="/usr/lib/java"


              Modify for your own requirements.