2 Replies Latest reply on May 26, 2004 1:25 AM by anand1976x

    Not able to generate proper .wsdl file with deploy.wsdd

    anand1976x Newbie

      Hi All I am on Chapter 9.
      and getting the following wsdl on axis page

      <?xml version="1.0" encoding="UTF-8" ?>
      - <wsdl:definitions targetNamespace="http://localhost:8080/axis/services/MyStoreLoginService" xmlns="http://schemas.xmlsoap.org/wsdl/" xmlns:apachesoap="http://xml.apache.org/xml-soap" xmlns:impl="http://localhost:8080/axis/services/MyStoreLoginService" xmlns:intf="http://localhost:8080/axis/services/MyStoreLoginService" xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/" xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/" xmlns:wsdlsoap="http://schemas.xmlsoap.org/wsdl/soap/" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
      <wsdl:portType name="StoreAccessLocal" />
      - <wsdl:binding name="MyStoreLoginServiceSoapBinding" type="impl:StoreAccessLocal">
      <wsdlsoap:binding style="rpc" transport="http://schemas.xmlsoap.org/soap/http" />
      </wsdl:binding>
      - <wsdl:service name="StoreAccessLocalService">
      - <wsdl:port binding="impl:MyStoreLoginServiceSoapBinding" name="MyStoreLoginService">
      <wsdlsoap:address location="http://localhost:8080/axis/services/MyStoreLoginService" />
      </wsdl:port>
      </wsdl:service>
      </wsdl:definitions>

      there is not method logginUser in it.

      I am using following deploy.wsdd file

      <deployment name="test" xmlns="http://xml.apache.org/axis/wsdd/" xmlns:java="http://xml.apache.org/axis/wsdd/providers/java">








      Please Help Me on This I am using
      JBoss - 3.2.3
      lomboz - 2.1.3
      axis - 1.1