3 Replies Latest reply on Nov 27, 2006 5:44 PM by steve tynor

    JBoss 4.0.4GA don't support java 5.0 new features(generics,

    zhang qiwen Newbie

      hello, everyone!

      I use this code snippet in welcome.jsp

      <%
       Iterator<String> categories = faqs.getAllCategories();
       while (categories.hasNext()) {
       String category = categories.next();
       }
      %>

      I deploy the .ear file to jboss correctly, but my browser display error message as follows.
      then I use Tomcat 5.5 to deploy it stand alone, it just work!!

      can anybody tells me how to configure jboss? thank you very much!

      Error Message:
      An error occurred at line: 12 in the jsp file: /welcome.jsp
      Generated servlet error:
      The type Iterator is not generic; it cannot be parameterized with arguments <String>
      
      An error occurred at line: 12 in the jsp file: /welcome.jsp
      Generated servlet error:
      Syntax error, parameterized types are only available if source level is 5.0