1 Reply Latest reply on Feb 22, 2008 2:45 AM by jaikiran pai

    Jboss Startup Error

    blah blou Newbie

      Hi...
      Im getting the following error while starting up jboss. I checked the previous posts in the forum..Couldn find a matching reply..

      Thanks in advance

      C:\jboss\bin>run.bat -Dlog4j.configuration=log4j-debug.properties
      ===============================================================================
      .
      JBoss Bootstrap Environment
      .
      JBOSS_HOME: C:\jboss\bin\\..
      .
      JAVA: C:\jdk1.5.0_10\bin\java
      .
      JAVA_OPTS: -Dprogram.name=run.bat
      .
      CLASSPATH: ;C:\jdk1.5.0_10\lib\tools.jar;C:\jboss\bin\\run.jar
      .
      ===============================================================================
      .
      10:41:15,742 INFO [Server] Starting JBoss (MX MicroKernel)...
      10:41:15,742 INFO [Server] Release ID: JBoss [WonderLand] 3.2.3 (build: CVSTag=
      JBoss_3_2_3 date=200311301445)
      10:41:15,742 DEBUG [Server] Using config: org.jboss.system.server.ServerConfigIm
      pl@b4d3d5
      10:41:15,742 DEBUG [Server] Server type: class org.jboss.system.server.ServerImp
      l
      10:41:15,742 INFO [Server] Home Dir: C:\jboss
      10:41:15,742 INFO [Server] Home URL: file:/C:/jboss/
      10:41:15,742 INFO [Server] Library URL: file:/C:/jboss/lib/
      10:41:15,742 INFO [Server] Patch URL: null
      10:41:15,742 INFO [Server] Server Name: default
      10:41:15,742 INFO [Server] Server Home Dir: C:\jboss\server\default
      10:41:15,742 INFO [Server] Server Home URL: file:/C:/jboss/server/default/
      10:41:15,742 INFO [Server] Server Data Dir: C:\jboss\server\default\data
      10:41:15,752 INFO [Server] Server Temp Dir: C:\jboss\server\default\tmp
      10:41:15,752 INFO [Server] Server Config URL: file:/C:/jboss/server/default/con
      f/
      10:41:15,752 INFO [Server] Server Library URL: file:/C:/jboss/server/default/li
      b/
      10:41:15,752 INFO [Server] Root Deployment Filename: jboss-service.xml
      10:41:15,762 INFO [Server] Starting General Purpose Architecture (GPA)...
      10:41:15,773 DEBUG [Server] Created MBeanServer: com.sun.jmx.mbeanserver.JmxMBea
      nServer@a56a7c
      10:41:15,773 DEBUG [Server] Boot url list: [file:/C:/jboss/server/default/conf/]

      10:41:15,773 DEBUG [Server] Creating loader for URL: file:/C:/jboss/server/defau
      lt/conf/
      10:41:15,783 DEBUG [Server] Failed to start
      javax.management.InstanceNotFoundException: JMImplementation:service=LoaderRepos
      itory,name=Default
      at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.getMBean(Defaul
      tMBeanServerInterceptor.java:1010)
      at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(DefaultM
      BeanServerInterceptor.java:804)
      at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(JmxMBeanServer.java:784
      )
      at org.jboss.system.server.ServerImpl.initBootLibraries(ServerImpl.java:
      499)
      at org.jboss.system.server.ServerImpl.doStart(ServerImpl.java:335)
      at org.jboss.system.server.ServerImpl.start(ServerImpl.java:291)
      at org.jboss.Main.boot(Main.java:150)
      at org.jboss.Main$1.run(Main.java:395)
      at java.lang.Thread.run(Thread.java:595)
      Failed to boot JBoss:
      javax.management.InstanceNotFoundException: JMImplementation:service=LoaderRepos
      itory,name=Default
      at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.getMBean(Defaul
      tMBeanServerInterceptor.java:1010)
      at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(DefaultM
      BeanServerInterceptor.java:804)
      at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(JmxMBeanServer.java:784
      )
      at org.jboss.system.server.ServerImpl.initBootLibraries(ServerImpl.java:
      499)
      at org.jboss.system.server.ServerImpl.doStart(ServerImpl.java:335)
      at org.jboss.system.server.ServerImpl.start(ServerImpl.java:291)
      at org.jboss.Main.boot(Main.java:150)
      at org.jboss.Main$1.run(Main.java:395)
      at java.lang.Thread.run(Thread.java:595)
      Press any key to continue . .

        • 1. Re: Jboss Startup Error
          jaikiran pai Master

           

          C:\jboss\bin>run.bat -Dlog4j.configuration=log4j-debug.properties


          Tried this on my local 3.2.3 setup with JDK1.5. Saw the same errors as you. This seems to be happening when you pass the -Dlog4j.configuration=log4j-debug.properties to the run.bat.

          I then changed the JDK to 1.4 and used the same command

          run.bat -Dlog4j.configuration=log4j-debug.properties


          JBoss started fine. I would recommend switching to JDK1.4