3 Replies Latest reply on Jan 23, 2009 8:01 AM by jaikiran pai

    non-HTTP Request Exception on a simple request

    Sergio Manero Newbie

      Hello,

      I'm testing a simple request POST to a servlet in a well-deployed war (unless in the logs and console it's so told). I have tested these environments:

      ENV1 : jdk1.6.11 | jboss-5.0.0.CR2 | run.bat -c default : Here everything is all right, i have got my "hello, newbie"

      ENV2 : jdk1.6.11 | jboss-5.0.0.GA | JAVA_OPTS and tips in release notes | run.bat -c default : This has a bizarre behaviour because i get

      javax.servlet.ServletException: non-HTTP request or response
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:800)
      org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
      org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
      org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:235)
      org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
      org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:190)
      org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:92)
      org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.process(SecurityContextEstablishmentValve.java:126)
      org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.invoke(SecurityContextEstablishmentValve.java:70)
      org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
      org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
      org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:158)
      org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
      org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:330)
      org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:828)
      org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:601)
      org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
      at java.lang.Thread.run(Thread.java:619)


      Maybe it's a question of some configuration options, but i don't find anything conclusive. Could you give me some hint? Thanks a lot.

        • 1. Re: non-HTTP Request Exception on a simple request
          Peter Johnson Master

          The exception stack trace you posted, was it displayed in your browser? If so, there should be a corresponding exception stack trace in the console log, please post that.

          Also, please post the source code for your servlet and for the web.xml file.

          When posting XML text or source code, enclose them in UBBCode "code" tags - you can do this by selecting the text and clicking the Code button above the editor window. Also, click the Preview button to ensure that the formatting is correct and the XML text shows up before posting.

          • 2. Re: non-HTTP Request Exception on a simple request
            Sergio Manero Newbie

            It's the exception stack trace in the console log. Finally i have got a solution, problem comes with libraries for GWT 1.5

            gwt-user.jar
            gwt-servet.jar

            In ENV1 there was and there is no problem at all.

            In ENV2 with JBossAS5.GA solution is not deploying gwt-user.jar.

            I have read that there has been some changes in ClassLoader so i suppose that ENV 1 runs because of some kind of bug, maybe.

            Anyway, thank you very much

            sergi

            • 3. Re: non-HTTP Request Exception on a simple request
              jaikiran pai Master

               

              In ENV2 with JBossAS5.GA solution is not deploying gwt-user.jar.


              Could you please give more details? Where was this jar placed? And could you give us a bit more details about your application and what it was trying to do when you ran into this issue?