5 Replies Latest reply on Jan 28, 2009 11:03 PM by Brett Lewinski

    JBoss Tools eclipse issue

    Brett Lewinski Newbie

      Hello -

      I am trying to get JBoss Tools working in eclipse ganymede. I did a manual install copying the downloaded plugins and features into the eclipse plugins and features directory. I did a eclipse -clean before restarting. After I create a base web project (I am trying to create a JSR286 portlet from a tutorial I found) I try to add a portlet to it. When I click Choose File>New>Other and then select the JBoss Web Tools>Portlet wizard I do not see any options for JBoss. I would appreciate an insight as to how I can get this working. I there is a better way to install JBoss Tools to an existing eclipse install I can try to reinstall. I previously tried to install via the eclipse Update Manager with no success.

      Thanks in advance!
      Brett

        • 1. Re: JBoss Tools eclipse issue
          Peter Johnson Master

          Did you add the JBoss Portlets | JBoss Core Portlet facet to your dynamic web project?

          Also, I had to go to Windows | Preferences | JBoss Tools | JBoss Portlets, and uncheck the “Check Runtimes for Portlet Components� option before the JBoss Portlet facet was selectable.

          • 2. Re: JBoss Tools eclipse issue
            Peter Johnson Master

            Wow, I like the translation for the open and closed quote symbols. ;-)

            • 3. Re: JBoss Tools eclipse issue
              Brett Lewinski Newbie

              Peter -

              Thanks for the reply I appreciate it. This morning I started over from scratch re-installing eclipse. I then through the Update Manager (my preferred method for installs) added the JBoss Tools and BIRT Update site. These were the instructions listed on the JBoss Tools Install page. When I click the Install button it indicates that Software Selections may be invalid. The following is what is provided in the details section:

              Cannot complete the request. See the details.
              Cannot find a solution satisfying the following requirements
              Match[requiredCapability:
              org.eclipse.equinox.p2.iu/org.eclipse.birt.doc.feature.group/[2.3.0.v200805131-22-7w31191728b,2.3.0.v200805131-22-7w31191728b]].


              I am not really sure what is missing. I think once I find this it should be all set. Do you know what this is or where I can get it?

              Thanks again for the reply!

              Brett

              • 4. Re: JBoss Tools eclipse issue
                Peter Johnson Master

                I can never figure out what I need to install based on the errro messages that the Eclipse updater provides. I guess if I knew the ins and outs of the OSGi configuration of all the Eclipse modules, I could figure it out.

                I know that when I install JBoss Tools, I always get an error like this. I think what I did was unclicked "JBoss BIRT Integration" and the error went away. Then the install went without any problems.

                • 5. Re: JBoss Tools eclipse issue
                  Brett Lewinski Newbie

                  Peter -

                  Thanks again for the info. So I finally got it all installed and working; here is what I did. As you suggested I disabled the "JBoss BIRT Integration" and tried to install. I still got a dependency issues this time with the JBoss TPTP (some testing plugin). So I disabled that as well and the install worked fine. I was able to use the JBoss Tools. Curiosity got the best of me and I was determined to get the TPTP and BIRT parts installed. I figured out what TPTP needed (it was just a dependency in the ganymede release) so I got that working. Then I was trying to get the details of the BIRT failure so all I checked was the JBoss BIRT Integration and hit install. Turns out it worked! I am assuming that something needed to already be installed from the JBoss package for it to work. I am 99.9% sure I didn't have anything else checked. I may do a re-install tomorrow for the heck of it. Anyhow I am psyched that I got it all working. Thanks for the information you provided; it was a big help!

                  Brett