0 Replies Latest reply on Aug 11, 2002 3:40 AM by Tom Jordon

    No Resource Manager Found Exception

    Tom Jordon Newbie

      Hi,

      I am using JBoss 3.0 and am having difficulty setting up a datasource with sqlserver. I am getting a No Resource Manager found error when deploying my ejbs.

      I have deployed the mssql-service.xml file and its included below. I have also included the following tag in my jboss.xml file. Any ideas as what I am doing wrong?

      Thanks
      Tom.

      Jboss.xml file:

      <resource-managers>

      <resource-manager res-class="">
      <res-name>jdbc/dbPool</res-name>
      <res-jndi-name>java:/dbPool</res-jndi-name>
      </resource-manager>

      </resource-managers>


      mssql-service.xml



      <!-- ======================================================================-->
      <!-- New ConnectionManager setup for Microsoft SQL Server 2000 driver -->
      <!-- You may download the latest Microsoft JDBC driver from *Microsoft* -->
      <!-- http://msdn.microsoft.com/downloads/default.asp?url=/downloads/sample.asp?url=/MSDN-FILES/027/001/779/msdncompositedoc.xml&frame=true -->
      <!-- Build jmx-api (build/build.sh all) and view for config documentation -->
      <!-- ===================================================================== -->


      <!--make the rar deploy! hack till better deployment-->
      jboss.jca:service=RARDeployer


      <depends optional-attribute-name="ManagedConnectionFactoryName">
      <!--embedded mbean-->

      <!--hack-->
      <depends optional-attribute-name="OldRarDeployment">jboss.jca:service=RARDeployment,name=Minerva JDBC LocalTransaction ResourceAdapter

      java:/dbPool
      <!--real attributes-->


      <config-property>
      <config-property-name>ConnectionURL</config-property-name>
      <config-property-type>java.lang.String</config-property-type>
      <config-property-value>jdbc:inetdae:localhost:1433?database=dev</config-property-value>
      </config-property>
      <config-property>
      <config-property-name>DriverClass</config-property-name>
      <config-property-type>java.lang.String</config-property-type>
      <config-property-value>com.inet.tds.TdsDriver</config-property-value>
      </config-property>
      <config-property>
      <config-property-name>UserName</config-property-name>
      <config-property-type>java.lang.String</config-property-type>
      <config-property-value>ebcuser</config-property-value>
      </config-property>
      <config-property>
      <config-property-name>Password</config-property-name>
      <config-property-type>java.lang.String</config-property-type>
      <config-property-value>ebcuser</config-property-value>
      </config-property>






      <depends optional-attribute-name="ManagedConnectionPool">
      <!--embedded mbean-->


      3
      15
      5000
      15
      <!--criteria indicates if Subject (from security domain) or app supplied
      parameters (such as from getConnection(user, pw)) are used to distinguish
      connections in the pool. Choices are
      ByContainerAndApplication (use both),
      ByContainer (use Subject),
      ByApplication (use app supplied params only),
      ByNothing (all connections are equivalent, usually if adapter supports
      reauthentication)-->
      ByContainer



      <depends optional-attribute-name="CachedConnectionManager">jboss.jca:service=CachedConnectionManager

      <!-- Include a login module configuration named MSSQLDbRealm.
      Update your login-conf.xml, here is an example for a
      ConfiguredIdentityLoginModule:

      <application-policy name = "MSSQLDbRealm">

      <login-module code = "org.jboss.resource.security.ConfiguredIdentityLoginModule" flag = "required">
      <module-option name = "principal">yourprincipal</module-option>
      <module-option name = "userName">yourusername</module-option>
      <module-option name = "password">yourpassword</module-option>
      <module-option name = "managedConnectionFactoryName">jboss.jca:service=LocalTxDS,name=dbPool</module-option>
      </login-module>

      </application-policy>

      NOTE: the application-policy name attribute must match the part of
      SecurityDomainJndiName after java:/jaas/, and the
      module-option name = "managedConnectionFactoryName"
      must match the object name of the ConnectionManager you are configuring here.
      -->
      <!--comment out this line if you want component managed security or want
      to use the default values in the ManagedConnectionFactoryProperties -->
      java:/jaas/MSSQLDbRealm
      java:/TransactionManager