0 Replies Latest reply on Oct 21, 2002 5:42 PM by Ed King

    Oracle datasource problem...starting and stopping the servic

    Ed King Newbie

      I have jBoss 2.4.8 running on a Windows 2000 box as a service, I also have Oracle running on the same box as a service. When the box is rebooted the jBoss service starts prior to the Oracle service and the Oracle datasource does not get bound.

      I get the following messages:

      21 Oct 2002 16:51:43,571 [ JBossMain] INFO - Creating XA Pool
      21 Oct 2002 16:51:43,631 [ JBossMain] INFO - XA Connection pool TangramDB bound to java:/TangramDB
      21 Oct 2002 16:51:44,813 [ JBossMain] ERROR - Can't get an XAConnection
      java.sql.SQLException: Io exception: The Network Adapter could not establish the connection
      at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:180)
      at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:222)
      at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:335)
      at oracle.jdbc.driver.OracleConnection.(OracleConnection.java:334)
      at oracle.jdbc.driver.OracleDriver.getConnectionInstance(OracleDriver.java:442)
      at oracle.jdbc.driver.OracleDriver.connect(OracleDriver.java:321)
      at java.sql.DriverManager.getConnection(Unknown Source)
      at java.sql.DriverManager.getConnection(Unknown Source)
      at org.jboss.pool.jdbc.xa.wrapper.XADataSourceImpl.getXAConnection(XADataSourceImpl.java:176)
      at org.jboss.pool.jdbc.xa.XAConnectionFactory.createObject(XAConnectionFactory.java:295)
      at org.jboss.pool.ObjectPool.createNewObject(ObjectPool.java:1014)
      at org.jboss.pool.ObjectPool.getObject(ObjectPool.java:668)
      at org.jboss.pool.jdbc.xa.XAPoolDataSource.getConnection(XAPoolDataSource.java:228)
      at org.jboss.jdbc.XADataSourceLoader.startService(XADataSourceLoader.java:415)
      at org.jboss.util.ServiceMBeanSupport.start(ServiceMBeanSupport.java:103)
      at java.lang.reflect.Method.invoke(Native Method)
      at com.sun.management.jmx.MBeanServerImpl.invoke(MBeanServerImpl.java:1628)
      at com.sun.management.jmx.MBeanServerImpl.invoke(MBeanServerImpl.java:1523)
      at org.jboss.configuration.ConfigurationService$ServiceProxy.invoke(ConfigurationService.java:967)
      at $Proxy0.start(Unknown Source)
      at org.jboss.util.ServiceControl.start(ServiceControl.java:79)
      at java.lang.reflect.Method.invoke(Native Method)
      at com.sun.management.jmx.MBeanServerImpl.invoke(MBeanServerImpl.java:1628)
      at com.sun.management.jmx.MBeanServerImpl.invoke(MBeanServerImpl.java:1523)
      at org.jboss.Main.(Main.java:209)
      at org.jboss.Main$1.run(Main.java:110)
      at java.security.AccessController.doPrivileged(Native Method)
      at org.jboss.Main.main(Main.java:106)
      21 Oct 2002 16:51:44,813 [ JBossMain] ERROR - Stopped


      I then attempt to start the datasource using the admin http service, once I know that the database is up and receive the following message:

      The MBeanServer throws a JMRuntimeException when calling operation[start] of [DefaultDomain:service=XADataSource,name=TangramDB] :
      javax.management.RuntimeMBeanException: RuntimeException thrown in operation start

      Anybody seen this issue?