0 Replies Latest reply on Jun 26, 2004 7:40 PM by Hillel Bilman

    Can't build JMS example chapter 4 example 1, any help apprec

    Hillel Bilman Newbie

      [examples-2.4.5]$ ant -Dchap=4 -Dex=1 run-example Buildfile: build.xml

      validate:

      fail_if_not_valid:

      init:
      [echo] Using jboss.dist=/usr/local/jboss-3.2.3

      compile:
      [javac] Compiling 1 source file to /home/hillel/jbossdocs/JBossBook-2.4.6/examples-2.4.5/build/classes

      run-example:

      run-example1:
      [echo] classpath=/usr/local/jboss-3.2.3/client/jbossall-client.jar:/usr/local/jboss-3.2.3/client/jboss-j2ee.jar:/usr/local/jboss-3.2.3/client/jboss-jaas.jar:/usr/local/jboss-3.2.3/client/jbossmq-client.jar:/usr/local/jboss-3.2.3/client/jbosssx-client.jar:/usr/local/jboss-3.2.3/client/jboss-client.jar:/usr/local/jboss-3.2.3/client/jnp-client.jar:/usr/local/jboss-3.2.3/client/log4j.jar:/usr/local/jboss-3.2.3/client/concurrent.jar:/usr/local/jboss-3.2.3/client/jacorb.jar:/usr/local/jboss-3.2.3/server/default/lib/jboss.jar:/home/hillel/jbossdocs/JBossBook-2.4.6/examples-2.4.5/build/classes:/home/hillel/jbossdocs/JBossBook-2.4.6/examples-2.4.5/src/resources
      [java] Begin sendRecvAsync
      [java] Exception in thread "main" javax.naming.NoInitialContextException: Can't find property: java.naming.factory.initial
      [java] at javax.naming.spi.NamingManager.getInitialContext(java.util.Hashtable) (/lib/ssa/libgcj.so.4.0.0)
      [java] at javax.naming.InitialContext.getDefaultInitCtx() (/lib/ssa/libgcj.so.4.0.0)
      [java] at javax.naming.InitialContext.getURLOrDefaultInitCtx(java.lang.String) (/lib/ssa/libgcj.so.4.0.0)
      [java] at javax.naming.InitialContext.lookup(java.lang.String) (/lib/ssa/libgcj.so.4.0.0)
      [java] at org.jboss.chap4.ex1.SendRecvClient.setupPTP() (Unknown Source)
      [java] at org.jboss.chap4.ex1.SendRecvClient.sendRecvAsync(java.lang.String) (Unknown Source)
      [java] at org.jboss.chap4.ex1.SendRecvClient.main(java.lang.String[]) (Unknown Source)
      [java] Java Result: 1

      BUILD SUCCESSFUL
      Total time: 0 seconds

      Any ideas what this error means?
      Any help appreciated.