2 Replies Latest reply on Nov 10, 2004 7:10 AM by Luc Texier

    starting problem

    Dmitry Fadeev Newbie

      Hello!

      I'm new to jboss technology.

      Anyway i'm starting jboss by calling run.bat located in bin directory of jboss on my XP platform and here is what i get:

      ===============================================================================
      .
       JBoss Bootstrap Environment
      .
       JBOSS_HOME: C:\Program Files\jboss-3.0.8\bin\\..
      .
       JAVA: C:\Program Files\Java\jdk1.5.0\bin\java
      .
       JAVA_OPTS: -Dprogram.name=run.bat
      .
       CLASSPATH: ;C:\Program Files\Java\jdk1.5.0\lib\tools.jar;C:\Program Files\jboss-3.0.8\bin\\run.jar
      .
      ===============================================================================
      .
      13:48:57,609 INFO [Server] JBoss Release: JBoss-3.0.8 CVSTag=JBoss_3_0_8
      13:48:57,640 INFO [Server] Home Dir: C:\Program Files\jboss-3.0.8
      13:48:57,640 INFO [Server] Home URL: file:/C:/Program Files/jboss-3.0.8/
      13:48:57,640 INFO [Server] Library URL: file:/C:/Program Files/jboss-3.0.8/lib/
      13:48:57,640 INFO [Server] Patch URL: null
      13:48:57,640 INFO [Server] Server Name: default
      13:48:57,640 INFO [Server] Server Home Dir: C:\Program Files\jboss-3.0.8\server\default
      13:48:57,640 INFO [Server] Server Home URL: file:/C:/Program Files/jboss-3.0.8/server/default/
      13:48:57,640 INFO [Server] Server Data Dir: C:\Program Files\jboss-3.0.8\server\default\db
      13:48:57,640 INFO [Server] Server Temp Dir: C:\Program Files\jboss-3.0.8\server\default\tmp
      13:48:57,656 INFO [Server] Server Config URL: file:/C:/Program Files/jboss-3.0.8/server/default/conf/
      13:48:57,671 INFO [Server] Server Library URL: file:/C:/Program Files/jboss-3.0.8/server/default/lib/
      13:48:57,671 INFO [Server] Root Deployemnt Filename: jboss-service.xml
      13:48:57,671 INFO [Server] Starting General Purpose Architecture (GPA)...
      13:48:57,734 ERROR [Server] start failed
      javax.management.InstanceNotFoundException: JMImplementation:service=LoaderRepository,name=Default
       at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.getMBean(DefaultMBeanServerInterceptor.java:1010)
       at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(DefaultMBeanServerInterceptor.java:804)
       at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(JmxMBeanServer.java:784)
       at org.jboss.system.server.ServerImpl.initBootLibraries(ServerImpl.java:440)
       at org.jboss.system.server.ServerImpl.doStart(ServerImpl.java:261)
       at org.jboss.system.server.ServerImpl.start(ServerImpl.java:221)
       at org.jboss.Main.boot(Main.java:148)
       at org.jboss.Main$1.run(Main.java:381)
       at java.lang.Thread.run(Thread.java:595)
      Press any key to continue . . .
      


      is there something wrong with my VM ? i have java version 1.5 ...

      Please help