2 Replies Latest reply on Apr 8, 2005 11:22 AM by zhang yubin

    how to use jboss-4.0.1sp1 in eclipse?

    zhang yubin Newbie

      I downloaded the lomboz plugin and update eclipse ide with it,but i found that the lomboz can only support jboss 2.44,not jboss-4.0.1sp1,how to selove this problem?thank you

        • 1. Re: how to use jboss-4.0.1sp1 in eclipse?
          zhang yubin Newbie

          Is there anybody who knows the answer to this.

          • 2. Re: how to use jboss-4.0.1sp1 in eclipse?
            zhang yubin Newbie

            i find the server file







            ${serverRootDirectory}
            ${serverRootDirectory}/server/${serverConfig}/deploy
            ${serverRootDirectory}/server/${serverConfig}/deploy
            ${serverRootDirectory}/server/${serverConfig}/deploy
            org.jnp.interfaces.NamingContextFactory
            jnp://${serverAddress}:1099
            org.jboss.Main
            ${serverRootDirectory}/bin
            -Dprogram.name=run.bat -Djava.endorsed.dirs=${serverRootDirectory}/bin/../lib/endorsed -Xms128m -Xmx512m
            -c ${serverConfig}
            org.jboss.Shutdown
            ${serverRootDirectory}/bin
            -cp ${classPathVariableName}/bin/shutdown.jar -Djboss.boot.loader.name=shutdown.bat
            -S

            JDK_TOOLS
            ${classPathVariableName}/bin/run.jar


            ${classPathVariableName}/client/jboss-j2ee.jar
            ${classPathVariableName}/client/jnp-client.jar
            ${classPathVariableName}/client/jbossall-client.jar
            ${classPathVariableName}/client/jboss-common-client.jar
            ${classPathVariableName}/client/jbosssx-client.jar
            ${classPathVariableName}/client/log4j.jar
            ${classPathVariableName}/server/default/lib/jnpserver.jar


            JDK_TOOLS
            ${classPathVariableName}/bin/run.jar
            ${classPathVariableName}/bin/shutdown.jar
            ${classPathVariableName}/client/jboss-j2ee.jar
            ${classPathVariableName}/server/${serverConfig}/lib/javax.servlet.jar
            ${classPathVariableName}/lib/jboss-system.jar
            ${classPathVariableName}/lib/concurrent.jar
            ${classPathVariableName}/server/${serverConfig}/lib/jboss.jar
            ${classPathVariableName}/server/${serverConfig}/lib/jnpserver.jar
            ${classPathVariableName}/server/${serverConfig}/lib/jpl-pattern.jar
            ${classPathVariableName}/server/${serverConfig}/lib/jpl-util.jar
            ${classPathVariableName}/server/${serverConfig}/lib/jboss-transaction.jar
            ${classPathVariableName}/server/${serverConfig}/lib/bcel.jar
















            but in my xdoclet.xml file i can not have version of the jboss server