0 Replies Latest reply on Mar 17, 2006 7:56 AM by Kuntal Roy

    selected configuration does not caontain the expected EJB3 l

    Kuntal Roy Newbie

      I am using JBossIDE-1.5RC2-Bundle-win32.zip for IDE and jboss-4.0.4RC1.zip for Application Server.

      When I am going to create a new EJB3 project using IDE, I am getting the following error:

      18:21:42,558 WARN [UDP] packet from /172.19.139.143:3781 has different version (0224) from ours (0227). This may cause problems
      18:21:42,558 ERROR [UDP] exception=java.io.InvalidClassException: org.jgroups.stack.IpAddress; local class incompatible: stream classdesc serialVersionUID = -1999612243427863834, local class serialVersionUID = -8753594169997651306
      at java.io.ObjectStreamClass.initNonProxy(ObjectStreamClass.java:519)
      at java.io.ObjectInputStream.readNonProxyDesc(ObjectInputStream.java:1546)
      at java.io.ObjectInputStream.readClassDesc(ObjectInputStream.java:1460)
      at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1693)
      at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1299)
      at java.io.ObjectInputStream.defaultReadFields(ObjectInputStream.java:1912)
      at java.io.ObjectInputStream.readSerialData(ObjectInputStream.java:1836)
      at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1713)
      at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1299)
      at java.io.ObjectInputStream.readObject(ObjectInputStream.java:339)
      at org.jgroups.protocols.PingHeader.readExternal(PingHeader.java:55)
      at org.jgroups.util.Marshaller.read(Marshaller.java:77)
      at org.jgroups.Message.readExternal(Message.java:491)
      at org.jgroups.protocols.UDP.handleIncomingUdpPacket(UDP.java:686)
      at org.jgroups.protocols.UDP$UcastReceiver.run(UDP.java:1294)
      at java.lang.Thread.run(Thread.java:595)

      Also, IDE is showing a messagebox containing a message that "The selected configuration does not caontain the expected EJB3 libraries. Please install JBoss with EJB3 libraries, or try another configuration.

      Please let me know the compatible versions.