4 Replies Latest reply on Sep 10, 2006 9:50 PM by Rob Stryker

    JBOSS-IDE ignoring run.conf when starting JBoss?

    Dave Belfer-Shevett Newbie

      I'm trying to enable JBoss under Eclipse to support JMX management when invoked frominside eclipse. If I alter ~/jboss/bin/run.conf and add the JMX management stuff to JAVA_OPTS, and run Jboss from the command line, I can run JConsole and connect to it without any problems.

      If I start up eclipse, and Server->Start JBoss, I cannot connect to it with JConsole. It appears that Jboss-IDE is launching JBoss in it's own fashion, rather than reading the run.conf file.

      If that's the case how do I pass parameter so the JVM that when JBoss-IDE starts JBoss, it sets appropriate values?

      In this case, the line I want to add is:
      JAVA_OPTS="$JAVA_OPTS -Dcom.sun.management.jmxremote"

      Thanks.

        • 1. Re: JBOSS-IDE ignoring run.conf when starting JBoss?
          Dave Belfer-Shevett Newbie

          Just a followup observation: it's absolutely clear that Jboss-IDE is ignoring the run.conf file. I made a change to the JAVA_OPTS line in run.conf - in fact put in a syntax error:

          Exception in thread "main" java.lang.NoClassDefFoundError: jalkfjaslkfjaslfkj


          From the command line (bin/run.sh), this throws that error. In Eclipse, starting JBoss throws no error.

          This is a fairly serious question, and I'm concerned that it's not being addressed - nowhere in the wiki or in the documentation that I have found. Can someone tell me how to configure JBoss's environment when launched from Eclipse?

          • 2. Re: JBOSS-IDE ignoring run.conf when starting JBoss?
            Rob Stryker Master

            You're 100% correct. Starting JBoss from inside eclipse does not execute the .bat or .sh files. It directly executes the main class of run.jar. For the time being, double-clicking on the server instance and editing it's launch configuration should allow you to add the proper parameters to the vm or program args.

            • 3. Re: JBOSS-IDE ignoring run.conf when starting JBoss?
              Dave Belfer-Shevett Newbie

               

              "rob.stryker@jboss.com" wrote:
              You're 100% correct. Starting JBoss from inside eclipse does not execute the .bat or .sh files. It directly executes the main class of run.jar. For the time being, double-clicking on the server instance and editing it's launch configuration should allow you to add the proper parameters to the vm or program args.


              While I thank you from the bottom of my geeky heart for the answer, might I suggest tihs is a very poor UI decision? Nowhere else does the UI use a double click for setting server properties (it's simple execution or opening configuration, and I had right clicked, clicked, properties selected, etc everywhere. But I hadn't tried double-clicking.

              Can something like "Properties..." be added to the right-click menu for the server view? That would have saved me 4-5 days of frustration.

              Thanks again for the help!

              • 4. Re: JBOSS-IDE ignoring run.conf when starting JBoss?
                Rob Stryker Master

                That part of the UI is run by the eclipse project "webtools" (upstream of us), however I will either put in a feature request to them or find some other way to ensure the UI is more user friendly.