0 Replies Latest reply on Jan 10, 2007 12:44 PM by Melinda Savoy

    Help needed on the All JBossIDE Plugin

    Melinda Savoy Newbie

      Our dev team is running Eclipse SDK Version: 3.2.1 Build id: M20060921-0945 on our local Windows XP boxes where we currently have jboss-4.0.5.GA as our local server.

      I just downloaded and installed the "All JBossIDE plugins" - JBossIDE-2.0.0.Beta2-ALL.zip. I only installed the following plugins and not the whole thing:

      Core Plug-in
      Ui Plug-in
      JBoss Core Plug-in
      JBossIDE First Run Plug-in
      JBoss Eclipse IDE Help Plug-in
      JBoss Development Core Plug-in
      JBoss Development J2EE Core Plug-in
      JBoss Development J2EE UI Plug-in
      JBoss Development J2EE XML UI Plug-in
      JBoss Development Test Core Plug-in
      JBoss Development Test UI Plug-in
      JBoss Development UI Plug-in
      JBoss Development Web Services Core Plug-in
      JBoss Development Web Services UI Plug-in
      JBoss Packaging Core Plug-in
      JBoss Packaging UI Plug-in
      JBossIDE Product
      JBoss UI Plug-in
      XDoclet Assist Plug-in
      XDoclet Core Plug-in
      XDoclet Runner Plug-in
      XDoclet UI Plug-in

      I realize this is just a Beta but I wanted to submit this question anyway and see if anyone had any suggestions as to what my problem could possibly be. The server comes up fine and in record time as opposed to using the JBoss 4.0.5.GA server. However when I start the server the STATE always comes up with a REPUBLISH value even after I PUBLISH. Even when I right-click the server and select publish the build does not occur and consequently the state remains as a republish value. In addition if I make a change to my code and then click publish after I right-click the server in the Server or JBoss Server View I am still seeing a REPUBLISH value in the STATE column and the change is obviously not seen by the server because the build does not occur.

      In addition to the publish issue, JBoss shutsdown my local LOG4J in my project and never comes back up.

      Any suggestions or direction would be greatly appreciated.

      Regards.