11 Replies Latest reply on Dec 3, 2007 6:10 AM by Max Rydahl Andersen

    Error in components.xml

    Per Lindfors Newbie

      Hi,

      I'm currently evaluating JBoss Tools and there's a problem with components.xml in Seam and the line: <transaction:no-transaction/>, which is producing an error in Eclipse after installing JBoss Tools. This was not a problem when only using Seam without Jboss Tools. Could it be that the schema is not found?

      This is my components.xml

      <?xml version="1.0" encoding="UTF-8"?>
      <components xmlns="http://jboss.com/products/seam/components"
       xmlns:core="http://jboss.com/products/seam/core"
       xmlns:persistence="http://jboss.com/products/seam/persistence"
       xmlns:security="http://jboss.com/products/seam/security"
       xmlns:transaction="http://jboss.com/products/seam/transaction"
       xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
       xsi:schemaLocation=
       "http://jboss.com/products/seam/core http://jboss.com/products/seam/core-2.0.xsd
       http://jboss.com/products/seam/persistence http://jboss.com/products/seam/persistence-2.0.xsd
       http://jboss.com/products/seam/security http://jboss.com/products/seam/security-2.0.xsd
       http://jboss.com/products/seam/transaction http://jboss.com/products/seam/transaction-2.0.xsd
       http://jboss.com/products/seam/components http://jboss.com/products/seam/components-2.0.xsd">
      
      
      
       <core:manager conversation-timeout="120000"
       concurrent-request-timeout="500"
       conversation-id-parameter="cid"/>
      
       <core:init debug="true" transaction-management-enabled="false" />
       <component name="org.jboss.seam.async.dispatcher" class="se.tullverket.sample.organization.pl.DummyComponent" />
      
      
       <transaction:no-transaction/>
      
      
      </components>
      


      This is my setup:
      Eclipse 3.3
      Seam 2.0.0.GA
      JBoss Tools 2.0.0.cr1

      /Per