1 Reply Latest reply on Sep 7, 2009 6:04 PM by Max Rydahl Andersen

    Project archives: Failed to create a new SAX parser

    Oliver Roell Newbie

      Hi,

      I have problems with the "Project archives" from the JBoss Tools 3.0.1

      Yesterday I have created a new WAR-file within the "Project archives" and it works.
      I was able to rebuild the WAR-file many times.
      Today it does not work. When I click on "Build project (Full)" I get the following error:

      'Build archive node' has encountered a problem.
      An internal error occurred during: "Build archive node".
      Failed to create a new SAX parser.

      When I want to open the archive I see only "Loading..." and no nodes.

      Without seeing the nodes I cannot delete the archive because without seeing a node I cannot delete the node.
      I can create a new archive with right-click, "New Archive", but nothing changes. I still see "Loading..." and no nodes.
      Therefore I have deleted the file .packages (which was empty) directly in the file system and then I was able to create a new archive.

      After that I have created a new test-project. In this project I can create a project archive and it works.
      But when I want to delete the archive, I get a similar error:

      'Save archive job' has encountered a problem.
      An internal error occurred during: "Save archive job".
      Failed to create a new SAX parser.

      All my archives are very small and were not changed after the automatic creation.
      I do not know why there is a permanent problem with the SAX parser.