5 Replies Latest reply on Oct 7, 2009 1:16 PM by nicolas duminil

    Can't install JBoss Tools in Eclipse 3.5 SR1

    nicolas duminil Novice

      Greetings,

      Trying to install JBoss Tools with Eclipse 3.5 SR1 for Windows Vista 32 bits.
      After having added the JBoss http://download.jboss.org/jbosstools/updates/stable site I'm proposed the following:

      JBoss Tools - 3.0.2.v200909151014R-H192-GA
      JBoss Tools Integration for TPTP, BIRT - 3.0.2.v200909151014R-H192-GA

      Selecting both and clicking Next gives:

      Cannot complete the install because of a conflicting dependency.
      Software being installed: JBoss ESB Tools 1.1.1.v200909151014R-H192-GA (org.jboss.tools.esb.feature.feature.group 1.1.1.v200909151014R-H192-GA)
      Software being installed: TPTP Profile On JBoss Server 1.0.0.v200909151014R-H192-GA (org.jboss.tools.tptp.feature.feature.group 1.0.0.v200909151014R-H192-GA)
      Only one of the following can be installed at once:
      International Components for Unicode for Java (ICU4J) 4.0.1.v20090415 (com.ibm.icu 4.0.1.v20090415)
      International Components for Unicode for Java (ICU4J) 3.8.1.v20080530 (com.ibm.icu 3.8.1.v20080530)
      International Components for Unicode for Java (ICU4J) 4.0.1.v20090822 (com.ibm.icu 4.0.1.v20090822)
      Cannot satisfy dependency:
      From: Hyades Trace Core UI 4.5.1.v200908290100 (org.eclipse.hyades.trace.ui 4.5.1.v200908290100)
      To: bundle com.ibm.icu [4.0.0,5.0.0)
      Cannot satisfy dependency:
      From: TPTP Instrumentation Annotation Support 4.5.1.v200901090100 (org.eclipse.tptp.platform.instrumentation.annotation 4.5.1.v200901090100)
      To: bundle org.eclipse.hyades.trace.ui [4.5.0,5.0.0)
      Cannot satisfy dependency:
      From: Instrument Core UI Feature 4.2.200.v200901090956-78778a8s733K353K3533 (org.eclipse.tptp.platform.instrumentation.ui.feature.group 4.2.200.v200901090956-78778a8s733K353K3533)
      To: org.eclipse.tptp.platform.instrumentation.annotation [4.5.1.v200901090100]
      Cannot satisfy dependency:
      From: TPTP Charting Service 4.3.0.v200906091631-7D77F8N9oB55W5L7L6G8B (org.eclipse.tptp.platform.report.feature.group 4.3.0.v200906091631-7D77F8N9oB55W5L7L6G8B)
      To: org.eclipse.tptp.platform.report.ui [4.1.400.v200905160100]
      Cannot satisfy dependency:
      From: TPTP Report UI 4.1.400.v200905160100 (org.eclipse.tptp.platform.report.ui 4.1.400.v200905160100)
      To: bundle com.ibm.icu [4.0.0,5.0.0)
      Cannot satisfy dependency:
      From: TPTP Platform Project 4.5.2.v200901090956-8F82EsM9TofPP4ogyX-bRjDoPYGV (org.eclipse.tptp.platform.runtime.feature.group 4.5.2.v200901090956-8F82EsM9TofPP4ogyX-bRjDoPYGV)
      To: org.eclipse.tptp.platform.instrumentation.ui.feature.group [4.2.200.v200901090956-78778a8s733K353K3533]
      Cannot satisfy dependency:
      From: TPTP Platform Project 4.6.1.v200908220100-8H8DFHq9a0jIg3EPLWGP4aXul5uw (org.eclipse.tptp.platform.runtime.feature.group 4.6.1.v200908220100-8H8DFHq9a0jIg3EPLWGP4aXul5uw)
      To: org.eclipse.tptp.platform.report.feature.group [4.3.0.v200906091631-7D77F8N9oB55W5L7L6G8B]
      Cannot satisfy dependency:
      From: SSE JavaScript Source Editor 1.0.200.v200805160650 (org.eclipse.wst.javascript.ui 1.0.200.v200805160650)
      To: bundle com.ibm.icu [3.4.4,4.0.0)
      Cannot satisfy dependency:
      From: JBoss ESB Tools 1.1.1.v200909151014R-H192-GA (org.jboss.tools.esb.feature.feature.group 1.1.1.v200909151014R-H192-GA)
      To: org.jboss.tools.esb.ui [1.1.1.v200909151014R-H192-GA]
      Cannot satisfy dependency:
      From: JBoss ESB Tools 1.1.1.v200909151014R-H192-GA (org.jboss.tools.esb.ui 1.1.1.v200909151014R-H192-GA)
      To: bundle org.jboss.tools.jst.web.ui 0.0.0
      Cannot satisfy dependency:
      From: Jsp Editor Plug-in 3.0.2.v200909151014R-H192-GA (org.jboss.tools.jst.jsp 3.0.2.v200909151014R-H192-GA)
      To: bundle org.eclipse.wst.javascript.ui 0.0.0
      Cannot satisfy dependency:
      From: Web UI 3.0.2.v200909151014R-H192-GA (org.jboss.tools.jst.web.ui 3.0.2.v200909151014R-H192-GA)
      To: bundle org.jboss.tools.jst.jsp 2.0.0
      Cannot satisfy dependency:
      From: TPTP Profile On JBoss Server 1.0.0.v200909151014R-H192-GA (org.jboss.tools.tptp.feature.feature.group 1.0.0.v200909151014R-H192-GA)
      To: org.eclipse.tptp.platform.runtime.feature.group 4.5.1