Development on SwitchYard - Eclipse Plug-ins

Version 3

    Development Environment

    Base Eclipse platform: Juno JEE

    Additional requirements:

    • EMF SDK
    • EMF Compare SDK
    • EMF Model Transaction SDK
    • EMF Validation Framework SDK
    • Graphiti SDK
    • Graphiti SDK Plus
    • Graphical Editing Framework Zest Visualization Toolkit SDK
    • m2e - Maven Integration for Eclipse
    • m2e-wtp - Maven Integration for WTP
    • m2e - Extensions Development Support (deselect "Group items by category")
    • JBoss Maven Integration
    • JBoss FreeMarker IDE
    • BPMN2 Modeler