Does anyone know whether Jboss 7.1.1 Final support EJB2.1 codes?

Version 1

    Dear all experts,

     

    I am going to migrate my application from JBOSS 6  to JBOSS 7. The application was written in legacy J2ee 1.4 codes and so it contains a large number of EJB2.1 codes. I have heard that JBOSS AS 7.0 is incompatible with EJB2.1 codes but Jboss 7.1.1 Final does support EJB2.1 codes. Am I correct?

     

    If I am correct, is there any migration guide or information that describes the changes I have to make to my legacy application for such migration?

     

    Please help.

     

    Best regards,

    John Chan