FromRC6RC7

Version 3

    Migrating from RC6 to RC7

     

    This list is non-exhaustive.  A better resource might be the release notes.

     

    • EJB3 specification has changed the packages of all interceptor interfaces from javax.ejb to javax.interceptor. 

      • javax.interceptor.InvocationContext

      • javax.interceptor.AroundInvoke

      • etc...

    • @PostConstruct/@PreDestroy have been moved from javax.ejb to javax.annotation

     

     

    Please help to improve this list.  Thank you!

     

    The EJB 3.0 RC7 implementation is only usable with JBoss 4.0.4.GA. The EJB 3.0 implementation that comes packaged with the JBoss 4.0.4.GA installer is the same as the standalone EJB 3.0 RC7 distribution with one exception. The standalone distribution has been patched to fix the EJBTHREE-573 JIRA bug. Also the JBoss Remoting jar has been patched to fix the SSL problems in the 4.0.4.GA release. If you don't need these fixes, then installing with the installer is fine.