JBossAOPJDK1.4

Version 2

    JDK 1.4 JBoss AOP Support

    JBoss AOP stopped supporting JDK 1.4 just before the 2.0 GA release. The latest stable JBoss AOP release that officially support JDK 1.4 is 1.5.6 and the latest CR release that supports JDK 1.4 is 2.0.0.CR8.

     

    Even though no release after is officially supported, it is possible to rebuild it to support JDK 1.4. Use JBoss Retro on the JBoss AOP classfiles and repackage the jar files.

     

    JDK 1.4.2 is end of life, please see http://java.sun.com/j2se/1.4.2/ for more details.