JbtUpgradeTo3x

Version 3

    This wiki list the user visible requirement/configuration changes in JBoss Tools that requries attention when updating to JBoss Tools 3 from JBoss Tools 2.

     

    JBoss Tools 3.0.alpha

     

    Eclipse requirements

     

    JBoss Tools 3 targets Eclipse 3.4/Ganymede and thus Eclipse 3.3 is not supported anymore.

     

    Legacy/deprecated plugins removed

     

    Some plugins (TODO: list them) were removed thus it is recommended to install JBoss Tools 3 in a fresh eclipse or at least remove all JBoss Tools 2 plugins to avoid Eclipse loading the old plugins.

     

    Removed Plugins

    The following three plugins were removed.

    org.jboss.ide.eclipse.firstrun

    org.jboss.ide.eclipse.jdt.j2ee.core

    org.jboss.ide.eclipse.jdt.j2ee.ui

     

    jdt.j2ee. provided classpath containers for J2EE 1.3 and 1.4 libraries. Their functionality has been moved to the org.jboss.ide.eclipse.as.classpath.core plugin and projects should require no change at all.  firstrun provided an API to allow us to throw up messages upon a workspaces first run after an upgrade. This was no longer in use and was removed.