Setting up Eclipse for Komodo Development

Version 4

    Komodo developers use the Eclipse IDE for development.  This document describes how to setup the Eclipse IDE for Komodo development.

     

    Prerequisites

    • MAVEN

    To build Komodo, you will need to install maven on your system.  If you don't have maven installed, you can download here.

    NOTE:  Currently we require maven 3.0.x for the Komodo build.  Verify by typing $mvn -version at a command prompt.

    The required jboss profiles are included in the provided settings.xml file.  Please edit your local maven installation configuration settings.xml to include these profiles.  Your installation configuration can be found at <my_maven_install>/conf/settings.xml.

    • JAVA

    To build Komodo, you will need to install java 1.7 on your system.

     

    Get the Source Code

    The official code repository for Komodo is located here on github.

    1. First, install git on your local system.  If you are new to git, please refer to these instructions.
    2. Follow our Get the Code section on github, which shows you how to create your own fork of the github repository and clone the fork to your file system.
    3. You are now ready to set up your Eclipse environment.

     

    Set Up Your Eclipse Development Environment

    If you need to install Eclipse, you can download it here: Eclipse Downloads. Download the 'Eclipse Standard' version, or any version that includes the PDE (Plugin Development Environment) feature.  Download the Eclipse Luna version.

     

    Once you have downloaded, go ahead and launch Eclipse.  Now, there are a few things you need to do:

     

    Verify JRE

    In Eclipse preferences, make sure that:

    • the installed JRE is set to 1.7 (Preferences -> Java -> Installed JREs), and
    • the Java compiler compliance level is set to 1.7 (Preferences -> Java -> Compiler -> Compiler compliance level).

     

    If you don't have 1.7 JRE, you can download one here: Java SE Downloads.

     

    Komodo Eclipse Preferences

    Make sure you have checked out the Komodo source code.

     

    The Komodo Eclipse IDE preferences are stored in the eclipse-preferences.epf file found in your local git repository at <INSTALL_LOC>/komodo/scripts/eclipse.

    Import this file using File -> Import... -> General -> Preferences. These preferences help ensure we maintain better coding standards and minimize the differences between changes made by committers and previous code versions.

     

    Install EGit Eclipse Components

    Komodo uses git as its source code management system. In order to work with git from within the IDE we recommend installing the EGit plugin , then setup the git repository in your eclipse dev environment. Here are the steps:

    1. Install the EGit plugins by running Help -> Install New Software.
    2. Select Luna - http://download.eclipse.org/releases/luna in the Work with: drop-down. Replace luna if you are using a different Eclipse installation.
    3. Under Collaboration, select Eclipse EGit.
    4. Click Next -> Next, accept licensing terms, and click Finish to finish the Install wizard.
    5. When prompted, restart your Eclipse IDE.
    6. In Eclipse, open the Git Repositories view by running Window -> Show View -> Other -> Git -> Git Repositories.
    7. On the Git Repositories view, click the link: Add an existing local Git repository (you already have a local git repo)
      • In the dialog, browse to your git repo on your local file system:  <INSTALL_LOC>/komodo
      • Click Finish to complete the wizard.

     

    Import Projects

    Make sure you have setup your Git repository in your IDE before importing the Komodo projects.

     

    Follow these steps to get the Komodo plugins into your Eclipse workspace:

    1. In Eclipse, open the Git Repositories view by selecting Window -> Show View -> Other -> Git -> Git Repositories.
    2. In the Git Repositories View, expand the komodo repository tree and select the Working Directory node.  Then Rt-Click >> Import Projects...  This starts the Import Projects Wizard.
    3. In the Import Projects from Git Repository dialog, select Import existing projects.  Expand the Working Directory folder, then select the plugins folder.  Click Next.
    4. On the next wizard page, make sure all plugins are selected.  Click Finish.
    5. The Komodo projects are now imported into your Eclipse environment.  Perform a full/clean build of all projects.