why i can't enable the xa-datasource

Version 1

    Hi everybody, I m beginner in Jboss.

     

    I'm doing some exercises, now I m trying to enable the xa-datasource, but it can't enable and show following error message.

    Unexpected HTTP response: 500

    Request
    {
        "xa-datasource-class" => "org.postgresql.xa.PGXADataSource",
        "pad-xid" => false,
        "wrap-xa-resource" => false,
        "same-rm-override" => false,
        "interleaving" => true,
        "name" => "PostgresXA",
        "password" => "password",
        "driver-name" => "postgresql-8.4-703.jdbc4.jar",
        "enabled" => false,
        "user-name" => "postgres",
        "security-domain" => "",
        "jndi-name" => "java:jboss/PostgresXA",
        "pool-name" => "",
        "transaction-isolation" => "TRANSACTION_READ_COMMITTED",
        "new-connection-sql" => "",
        "connection-url" => "",
        "driver-class" => "",
        "valid-connection-checker-class-name" => "",
        "check-valid-connection-sql" => "select 1 from principals",
        "background-validation" => false,
        "background-validation-millis" => 60000L,
        "validate-on-match" => false,
        "stale-connection-checker-class-name" => "",
        "exception-sorter-class-name" => "",
        "prepared-statements-cache-size" => -1L,
        "share-prepared-statements" => false,
        "use-ccm" => false,
        "operation" => "enable",
        "address" => [
            ("profile" => "ha"),
            ("subsystem" => "datasources"),
            ("xa-data-source" => "PostgresXA")
        ]
    }

    Response

    Internal Server Error
    {
        "outcome" => "failed",
        "result" => undefined,
        "failure-description" => "JBAS010839: Operation failed or was rolled back on all servers.",
        "rolled-back" => true,
        "server-groups" => {"main-server-group" => {"host" => {"master" => {"server-one" => {"response" => {
            "outcome" => "failed",
            "failure-description" => "JBAS010453: Data-source.xa-config-property service [service jboss.xa-data-source-config.PostgresXA.xa-datasource-properties.portNumber] is already started",
            "rolled-back" => true
        }}}}}}
    }

     

    what is the problem.

    thank you