1 Reply Latest reply: Jun 10, 2012 4:47 PM by Tomaz Cerar RSS

    jboss-as-7.1.1.Final: EAR deployed: JSP not found

    ganesh jadhav Newbie

      Hi,

      I recently downloaded jboss-as-7.1.1.Final, and trying few things. We have application running on JBOSS 6.1.0, we are thinking of moving it to jboss 7.

       

       

      currently i am trying to deploy a EAR , with a WAR file only. The WAR contains a servlet and a jsp.

       

      MDB.ear

                  ----->META-INF

                  ----->QueueSender.war

                                      ------>WEB-NF

                                                       ----->classes

                                                       ------>lib (servlet code jar)

                                                       ------>web.xml

                                                           

                                      ------>1.jsp                     

       

      I copied the ear in the folder :jboss-as-7.1.1.Final\standalone\deployments

       

      I started the app server using the : standalone.bat -Djboss.socket.binding.port-offset=100 -server-config=standalone-full-ha.xml

       

      the server console shows that the ear is deployed successfully.

      This is my web.xml

       

      <servlet>

      <servlet-name>QueueSenderServlet</servlet-name>

      <servlet-class>com.gj.as7.me.QueueSenderServlet</servlet-class>

      <load-on-startup>1</load-on-startup>

      </servlet>

      <servlet-mapping>

      <servlet-name>QueueSenderServlet</servlet-name>

      <url-pattern>/QueueSenderServlet</url-pattern>

      </servlet-mapping>

       

       

      application.xml

       

      <?xml version="1.0" encoding="UTF-8"?>
      <application version="5" xmlns="http://java.sun.com/xml/ns/javaee"
                    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
                    xsi:schemaLocation="http://java.sun.com/xml/ns/javaee
      http://java.sun.com/xml/ns/javaee/application_5.xsd">

        <!-- <module>
             <ejb>MDB3.jar</ejb>
         </module>-->
         <module>
      <web>
          <web-uri>QueueSender.war</web-uri>
          <context-root>/QueueSender</context-root>
      </web>
         </module>
      </application>

       

      I can access this servlet using the link  :http://localhost:8180/QueueSender/QueueSenderServlet

       

      But when i try to access the 1.jsp   :http://localhost:8180/QueueSender/1.jsp

      it says 404, /QueueSender/1.jsp  resource not found.

       

      there is other observation, i created a web application only, WAR file (with 1.jsp),  and deployed only WAR, i could access the 1.jsp.

       

      Why 1.jsp is not found when it is part of the EAR. I am confused, please help.

       

      Regards

      Ganesh