1 Reply Latest reply on Oct 13, 2017 8:47 PM by Amos Feng

    Java 9 and javax.transaction

    Klemen Ferjancic Newbie

      Hello

       

      I've seen this  JTA API on Java 9 ? and I do not quite understand what the end user should actually do. I am migrating a microservice framework to java 9 and most of javax.transaction classes are now missing.

       

      As far as I understand, I should not use "requires java.transaction" since it only contains a subset and is deprecated. Ideally I'd need to require a module that exports full JavaEE JTA packages. Does or will narayana export the full API as a module?

      Is there some other dependency that does this right now or is it basically not possible to use JTA with java 9 as of right now?

       

      Best regards, cen