2 Replies Latest reply on Oct 19, 2005 7:02 PM by Thomas Diesler

    Doc/lit ws from WSDL not working

    Alan Moore Newbie

      I'm working on a doc/lit style web service and am trying to implement the server side starting from WSDL.

      The WSDL I'm using is generated by a .NET app and I need to create a web service from it. I followed all the instructions I could find in the wiki and in the forums to no avail.

      I'm using the wsdp wscompile -import and have tried all the combinations of -features to create a wrapped style service but I continue to get the error from JBoss:

      org.jboss.axis.InternalException: java.lang.Exception: The OperationDesc for xxx was not synchronized to a method of org.whaterver.example.SomeInterfaceSoap.

      Versions:

      JBoss 4.0.2
      JWSDP: 1.6

      From the instructions in:

      http://wiki.jboss.org/wiki/Wiki.jsp?page=WSDOCServiceStepByStep

      I'm told to make sure the interface and implementation have been wrapped in a single param and return value and it seems that the switches I've given to wscompile are doing this correctly.

      The instructions mentioned above assume I'm working from a java interface but I'm starting from WSDL and using -import with wscompile.

      Are there known issues with implementing a doc/lit ws starting from wsdl?

      When I run the same web service from within 4.0.3, I get a different error:

      java.lang.IllegalArgumentException: Illegal argument passed to ParameterDesc.setJavaType. The java type org.whatever.example.MyMethodsInputParameter does not match the mode inout

      I've seen this before in a rpc style Axis web app when a class compiled with one version of axis is run under a newer version of axis runtime.

      I know it would help if I gave you all the gory details but I'm just hoping there is a FAQ or that this is a well known problem. If you really need the files, I'll have to strip them down to a smaller example.

      Thanks in advance.

      alan