5 Replies Latest reply on Oct 28, 2005 9:50 AM by Mark Waschkowski

    Problem with AlwaysModifySOAPAddress?

    Mark Waschkowski Newbie

      Hi All,

      I have a problem where I've set AlwaysModifySOAPAddress=false in my

      jboss-4.0.2\server\x\deploy\jboss-ws4ee.sar\META-INF\jboss-service.xml

      file and I supplied a url in the wsdl that I generated from wscompile, but the url still gets overridden. It doesn't look to me like that should happen, but perhaps there is some other dependency that wasn't discussed in the forums (which I've scoured). Anyone know for sure why the wsdl still gets deployed to:
      localhost:8080
      instead of the URL specified in the wsdl?

      As well, does anyone know if there is a way to specify the address when using the wscompile tool? I've tried to use HTTPProxy option but it didn't work either..

      Cheers,

      Mark



      jboss:service=WebService
      <!--
      The WSDL that is a required deployment artifact for an endpoint has a <soap:address>
      element which points to the location of the endpoint. JBoss supports rewriting of that soap address.

      If the content of <soap:address> is a valid URL, JBoss will not rewrite it unless AlwaysModifySOAPAddress=true
      If the content of <soap:address> is not a valid URL, JBoss will rewrite it using the attribute values given below.
      -->
      ${jboss.bind.address}
      8443
      8080
      false

      org.jboss.webservice.server.InvokerProviderEJB
      org.jboss.webservice.server.InvokerProviderJSE



      From wsdl:
      <soap:address location="http://x:8999/y/z/SoapRequest?wsdl"/>