2 Replies Latest reply on Mar 29, 2006 1:05 AM by Stefan Frank

    org.jboss.axis.AxisFault: The prefix

    Stefan Frank Newbie

      I'm using a document\literal ws that is generated via wscompile from a given wsdl with the option nodatabinding (as I want to do my mapping via xmlbeans). I'm getting correctly deployable ports, with the only complain on deploy being:

      16:13:44,610 WARN [JavaWsdlMapping] Cannot find jaxrpc-mapping for type: {http://signup.ull.tiscali.netpioneer.de/types}ullOrder
      16:13:44,611 WARN [TypeMappingDescription] Class not found: javax.xml.soap.ullOrder
      16:13:44,614 INFO [AxisService] WSDD published to: /opt/java/jboss-4.0.3-all/server/default/data/wsdl/ullworkflowsystem.ear/workflowsystem-web-0.1.war/SignupService.wsdd
      


      which I suppose is ok: The signature on the Enpoint-Implementations give me the raw SOAPElements and I want to do my de-serialization manually.

      However, when I try to access the webservice, I'm getting:

      javax.xml.soap.SOAPException: org.jboss.axis.AxisFault: The prefix "xmlns" cannot be bound to any namespace explicitly; neither can the namespace for "xmlns" be bound to any prefix explicitly.
       at org.jboss.axis.MessagePart.getEnvelope(MessagePart.java:1107)
       at org.jboss.webservice.server.ServerEngine.invoke(ServerEngine.java:59)
       at org.jboss.axis.transport.http.AxisServlet.doPost(AxisServlet.java:911)
       at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
       at org.jboss.axis.transport.http.AxisServletBase.service(AxisServletBase.java:370)
       at javax.servlet.http.HttpServlet.service(HttpServlet.java:810)
       at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
       at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
       at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:81)
       at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
       at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
       at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
       at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
       at org.jboss.web.tomcat.security.CustomPrincipalValve.invoke(CustomPrincipalValve.java:39)
       at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:159)
       at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:59)
       at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
       at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
       at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
       at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
       at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856)
       at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:744)
       at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
       at org.apache.tomcat.util.net.MasterSlaveWorkerThread.run(MasterSlaveWorkerThread.java:112)
       at java.lang.Thread.run(Thread.java:595)
      
      


      tcpmon shows the following for the envelope:

      <env:Envelope
       xmlns:env="http://schemas.xmlsoap.org/soap/envelope/"
       xmlns:xsd="http://www.w3.org/2001/XMLSchema"
       xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
       xmlns:enc="http://schemas.xmlsoap.org/soap/encoding/"
       xmlns:ns0="http://signup.ull.tiscali.netpioneer.de/types">
      


      which looks ok to me. The payload also looks ok, and I have comfirmed, that I can use XMLBeans to de-serialize the soap-body again.

      I'm puzzled, and don't have the slightest idea anymore, what is going wrong here - has anybody seen a similar error before???!

      Thx for any help
      stefan

        • 1. Re:  org.jboss.axis.AxisFault: The prefix
          Kyle Duncan Newbie

          I have run into a similar problem.

          I am trying to use a wscompile generated webservice with the nodatabinding feature. To create the outgoing soapelement, I used the addDocument method of org.jboss.axis.message.SOAPBodyImpl.

          During this operation, JBoss's implementation of SerializationContext (jboss 4.0.2, from axis-ws4ee.jar) is converting my 'xmlns=namespaceuri' into 'xmlns:xmlns=namespaceuri', which is illegal.

          Due to this, I get the following error message when trying to parse:
          org.xml.sax.SAXParseException: The prefix "xmlns" cannot be bound to any namespace explicitly; neither can the namespace for "xmlns" be bound to any prefix explicitly.

          I downloaded the source and modified SerializationContextImpl to prevent this from happenning, but even after that I get the same exact error message when trying to parse.

          Did you ever find the cause of this problem?



          • 2. Re:  org.jboss.axis.AxisFault: The prefix
            Stefan Frank Newbie

            Hi Kyle,

            wow, this is terribly long ago. Yes, we did find a solution, but I do not remember exactly what we did: However, the error-message was more than misleading, the error had nothing to do with the namespace-declararation. I vaguely remember that I still had a soap-encoded parameter in my wsdl. If you have migrated your wsdl from an rpc to a document\literal service, you may have a similar problem.

            Hope this helps (at least a bit..)

            cheers
            stf