5 Replies Latest reply on Jan 6, 2006 6:01 AM by Thomas Diesler

    Unable to deploy typemapping -> ClassNotFoundException

    Björn Bredohl Newbie

      Hi,
      I am trying to use ws4ee on JBoss 4.0.3 SP1.

      My webservice works fine with rpc/literal, but when I change to document style webservice and deploy it, I get the following error:

      ERROR [WSDDService] Unable to deploy typemapping: {urn:blablub}blablub
      java.lang.ClassNotFoundException: No ClassLoaders found for: org.apache.axis.encoding.ser.BeanSerializerFactory
      at org.jboss.mx.loading.LoadMgr3.beginLoadTask(LoadMgr3.java:198)
      at org.jboss.mx.loading.RepositoryClassLoader.loadClassImpl(RepositoryClassLoader.java:475)
      at org.jboss.mx.loading.RepositoryClassLoader.loadClass(RepositoryClassLoader.java:377)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
      at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
      at java.lang.Class.forName0(Native Method)
      at java.lang.Class.forName(Class.java:164)

      ...


      The class is in the axis-ws4ee.jar in the server/all/deploy/jboss-ws4ee.sar dir. I try to copy this file in the server/all/lib dir, but I get the same error.

      Does someone have any solution for my problem?

      Thanks in advance,
      Björn

        • 1. Re: Unable to deploy typemapping -> ClassNotFoundException
          Wayne Adams Newbie

          Sorry this isn't an answer. It's a request for some help to definitively answer this question, which keeps getting posted without a satisfactory answer. I have a doc/literal WS which deployed just fine as a .wsr on 3.2.7, deploys as-is on the latest Sun app server, and does not deploy on 4.03 sp1. I could upload a large set of files, but I think what is really needed here is a systematic set of steps to follow. It can't be that hard. Hint: doc/literal must have different issues than rpc/literal.

          I've tried a number of approaches with a ws4ee-deployment.xml file, and so on, and continue to get either a "could not find deserializer for type" or a "Null serializer factory specified" or no-class-def-found when trying to include the classes ref'd in the mapping file.

          We're encouraged to use wscompile -- but what to do with the serializer classes generated by it? They reference Sun-specific packages. Leave them out -- no serialization/deserialization; put them in -- no class def found (with or without the Sun .jars), etc. I'd greatly appreciate it if someone could provide the definitive answer to this problem. This is a super-simple doc/literal, one-operation WS that, as I said, deploys with no troubles elsewhere. TIA.

          Wayne

          • 2. Re: Unable to deploy typemapping -> ClassNotFoundException
            Jason Greene Master

             

            "bbredohl" wrote:
            Hi,
            I am trying to use ws4ee on JBoss 4.0.3 SP1.

            My webservice works fine with rpc/literal, but when I change to document style webservice and deploy it, I get the following error:

            ERROR [WSDDService] Unable to deploy typemapping: {urn:blablub}blablub
            java.lang.ClassNotFoundException: No ClassLoaders found for: org.apache.axis.encoding.ser.BeanSerializerFactory
            at org.jboss.mx.loading.LoadMgr3.beginLoadTask(LoadMgr3.java:198)
            at org.jboss.mx.loading.RepositoryClassLoader.loadClassImpl(RepositoryClassLoader.java:475)
            at org.jboss.mx.loading.RepositoryClassLoader.loadClass(RepositoryClassLoader.java:377)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
            at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
            at java.lang.Class.forName0(Native Method)
            at java.lang.Class.forName(Class.java:164)

            ...


            The class is in the axis-ws4ee.jar in the server/all/deploy/jboss-ws4ee.sar dir. I try to copy this file in the server/all/lib dir, but I get the same error.

            Does someone have any solution for my problem?

            Thanks in advance,
            Björn


            This looks like a corrupted jboss instance. Can you doing a fresh install and see if the problem occurs?

            -Jason

            • 3. Re: Unable to deploy typemapping -> ClassNotFoundException
              Jason Greene Master

               

              "wayne.adams" wrote:
              Sorry this isn't an answer. It's a request for some help to definitively answer this question, which keeps getting posted without a satisfactory answer. I have a doc/literal WS which deployed just fine as a .wsr on 3.2.7, deploys as-is on the latest Sun app server, and does not deploy on 4.03 sp1. I could upload a large set of files, but I think what is really needed here is a systematic set of steps to follow. It can't be that hard. Hint: doc/literal must have different issues than rpc/literal.

              I've tried a number of approaches with a ws4ee-deployment.xml file, and so on, and continue to get either a "could not find deserializer for type" or a "Null serializer factory specified" or no-class-def-found when trying to include the classes ref'd in the mapping file.

              We're encouraged to use wscompile -- but what to do with the serializer classes generated by it? They reference Sun-specific packages. Leave them out -- no serialization/deserialization; put them in -- no class def found (with or without the Sun .jars), etc. I'd greatly appreciate it if someone could provide the definitive answer to this problem. This is a super-simple doc/literal, one-operation WS that, as I said, deploys with no troubles elsewhere. TIA.

              Wayne


              Please don't hijack another person's thread. It only makes it harder for them to see the answer to their question.

              http://wiki.jboss.org/wiki/Wiki.jsp?page=WSDOCServiceStepByStep explains how to create a doc/literal web service. If it is a wrapped service then the only classes you need (besides your endpoint) is the Request and Response structs. You do not need a ws4ee-deployment.xml file, and you should try to avoid using it unless it is absolutely required.

              If you have further questions please post this as a separate thread.

              Thanks,
              -Jason


              • 4. Re: Unable to deploy typemapping -> ClassNotFoundException
                Björn Bredohl Newbie

                 

                "jason.greene@jboss.com" wrote:

                This looks like a corrupted jboss instance. Can you doing a fresh install and see if the problem occurs?

                -Jason


                Hi, I installed a new version (from CVS), but there was the same error. I changed from Document Style to RPC/literal, and I have no problems with deserialization/serialization.

                Thanks for your help,
                Björn

                • 5. Re: Unable to deploy typemapping -> ClassNotFoundException
                  Thomas Diesler Master

                  This class

                  org.apache.axis.encoding.ser.BeanSerializerFactory
                  


                  does not exist, it should read

                  org.jboss.axis.encoding.ser.BeanSerializerFactory
                  


                  There must be a config file that specifies the incorrect serializer factory - maybe your ws4ee-deployment.xml