7 Replies Latest reply on Jan 9, 2006 1:11 AM by itomer H

    about juddi-service.sar in 4.0.3SP1, is it missing or else?

    itomer H Newbie

      hi, i now need some function about web service registry.

      and i found that juddi-service.sar is integrated in my 4.0.2/all, and there are some posts about how to configure it in JBoss forum.

      but in 4.0.3SP1, juddi-service.sar is missing, under server/all/deploy, and i could not find it in a clean build either.

      what happened to juddi-service.sar?

      will it be ok if i just copy the juddi-service.sar in 4.0.2 and put it under 4.0.3/all/deploy?

        • 2. Re: about juddi-service.sar in 4.0.3SP1, is it missing or el
          itomer H Newbie

          thanks for the reply. I have seen those pages.


          The UDDI v2 jUDDI service you will find in all/juddi-service.sar


          but my question is: i could not find the juddi sar package coming along with my 4.0.3SP1 build. yet i do can find it coming with 4.0.2.

          now where should i find one juddi sar to put it under 4.0.3 server/all/deploy?
          1) will i just copy the sar package from 4.0.2 to 4.0.3? will that be ok?cause i saw in the wiki page that juddi sar work fine in 4.0.2 but throws exception in 4.0.3 rc2

          2) i also notice that there is one juddi-service.sar.zip file attached in wiki page. would that one be the right sar pack? http://wiki.jboss.org/wiki/Wiki.jsp?page=JAXR



          • 3. Re: about juddi-service.sar in 4.0.3SP1, is it missing or el
            Anil Saldanha Master

            Whats the matter? Why is there a false alarm on the non-availability of juddi-service.sar in the all/deploy directory?

            asaldhana@JBOSS-49354B0A2 ~/jboss-4.0.3sp1/server/all/deploy
            $ ls
            bsh-deployer.xml jbossjca-service.xml
            cache-invalidation-service.xml jbossweb-tomcat55.sar
            client-deployer-service.xml jms
            cluster-service.xml jmx-console.war
            deploy-hasingleton-service.xml jmx-invoker-service.xml
            deploy.last jsr88-service.xml
            ear-deployer.xml juddi-service.sar
            ejb-deployer.xml mail-ra.rar
            hsqldb-ds.xml mail-service.xml
            httpha-invoker.sar management
            iiop-service.xml monitoring-service.xml
            jboss-aop.deployer properties-service.xml
            jboss-bean.deployer schedule-manager-service.xml
            jboss-ha-local-jdbc.rar scheduler-service.xml
            jboss-ha-xa-jdbc.rar snmp-adaptor.sar
            jboss-local-jdbc.rar sqlexception-service.xml
            jboss-ws4ee.sar tc5-cluster-service.xml
            jboss-xa-jdbc.rar uuid-key-generator.sar
            


            This is a fresh install of 4.0.3sp1 on my computer. Can you see it there?

            Either I am hallucinating or you are. ;)

            Lets dig into the juddi-service.sar to make you believe.

            asaldhana@JBOSS-49354B0A2 ~/jboss-4.0.3sp1/server/all/deploy
            $ cd juddi-service.sar/
            
            asaldhana@JBOSS-49354B0A2 ~/jboss-4.0.3sp1/server/all/deploy/juddi-service.sar
            
            $ ls
            META-INF juddi-service.jar juddi.jar juddisaaj.jar juddiws.war scout.jar
            


            • 4. Re: about juddi-service.sar in 4.0.3SP1, is it missing or el
              itomer H Newbie

              many thanks for the reply.
              i must say it is very very wired indeed. :-(
              i double check my server/all/deploy, and it looks like the following.

               sqlexception-service.xml
               jbossjca-service.xml
              [http-invoker.sar] jdbc-metadata-service.xml
              [jboss-aop.deployer] jmx-invoker-service.xml
              [jboss-bean.deployer] jsr77-service.xml
              [jboss-ws4ee.sar] jta-service.xml
              [jms] invokers-service.xml
              [jmx-console.war] mail-service.xml
              [jbossweb-tomcat55.sar] mail-ra.rar
              [management] naming-service.xml
              [ejb3.deployer] properties-service.xml
              xmlresolver-service.xml scheduler-service.xml
              attrpm-service.xml schedule-manager-service.xml
              binding-service.xml security-service.xml
              bsh-deployer.xml uuid-key-generator.sar
              cache-invalidation-service.xml tc5-cluster-service.xml
              client-deployer-service.xml monitoring-service.xml
              dynclassloader-service.xml ejb3-clustered-sfsbcache-service.xml
              ear-deployer.xml ejb3-entity-cache-service.xml
              ejb-timer-service.xml ejb3-interceptors-aop.xml
              ejb-deployer.xml cluster-service.xml
              hsqldb-ds.xml mysql-ds.xml
              jboss-ha-local-jdbc.rar
              jboss-ha-xa-jdbc.rar
              jboss-local-jdbc.rar
              jboss-xa-jdbc.rar
              

              i installed 4.0.3SP1 from the "run installer" from JEMS product download page.
              and my two teammates downloaded 4.0.3SP1 from "run installer" too, and they do not have juddi-service.sar package either and have the same directory like me.

              "juddi-service.sar" is indeed missing in my 4.0.3SP1 build, and there are some other places that do not match the list in your post, such as "jsr77-service"(yet "jsr88-service" in your post)


              but i download the whole zip from "download" link, and choose the biggest zip file "jboss-4.0.3SP1.zip". now it looks fine and juddi-service.sar is in it.

              that is why i feel so wierd. is there something wrong with the installer?

              if the correct build is what i get from the download zip file, then what is the jboss 4.0.3SP1 build that we have been using for about 3 months from the "run installer"?

              i check the cache file, RMjboss-4.0.3SP1-installer.jar, it is about 47.059kb and date is 12-18-2005, under
              C:\Documents and Settings\xxxxx(name omitted)\Application Data\Sun\Java\Deployment\cache\javaws\http\Dinternap.dl.sourceforge.net\P80\DMsourceforge\DMjboss

              when i run the installer again, it did say "checking for the newest version", but no additional jars are downloaded.

              i do not know why, this question is totally beyond me. :-(

              anyway, the problem is clear and juddi-service.sar is found.
              i will tell my teammates to change the server platform tomorrow, and i would start my own work soon.

              thanks again :-)

              • 5. Re: about juddi-service.sar in 4.0.3SP1, is it missing or el
                itomer H Newbie

                just one more thing,

                i see the JEMS download page.

                NOTE: EJB 3.0 can be installed by choosing "Run Installer" or by downloading and running jboss-4.0.3SP1-installer.jar.


                if use "run installer" method, ejb3.deployer is coming with 4.0.3SP1 build as specified.
                but juddi-service.sar is missing in this 4.0.3 build.

                so i am wondering whether this "run installer" build is for ejb3 development only and is not supposed to support some other services, such as juddi-service, or jsr88-service?

                if that is it, i think it is my fault not to understand installation instruction correctly. :-(

                now, what i need to do is following the EJB 3 installation instructions and put the ejb3.deployer and some other xml conf files in deploy directory of the newly 4.0.3SP1 build with juddi-service.sar, right? if i want to use both EJB 3 and juddi.

                sorry for the inconvenience caused by me.

                • 6. Re: about juddi-service.sar in 4.0.3SP1, is it missing or el
                  Anil Saldanha Master

                  JUDDI does not come into picture with ejb3.0 development. Wrt the installer, I am not sure, if all the services that come with the standard full zip file, are provided by the installer. Need to look at the installer to answer that.

                  But anyway, since your problem is solved, good luck with the project. :-)

                  • 7. Re: about juddi-service.sar in 4.0.3SP1, is it missing or el
                    itomer H Newbie

                    thanks a lot.
                    this post is closed.

                    it is really my wrong.

                    maybe it would be better if there can be some notes about this, for some JBoss newbie lke me. such as, "Warning! JBoss EJB 3 build may not contain all the standard services."

                    when i used the "run installer" and choosed "All", i assumed that it would install all the standard services by default. but clearly i was wrong. :-)