0 Replies Latest reply on Mar 22, 2006 3:04 PM by Saikat Kanjilal

    Error Deploying A WebService In JBoss 4.0.4 with tomcat 5.5

    Saikat Kanjilal Newbie

      Hello:
      I wrote a webservice based on the tutorial provided and am deploying the webservice in jboss, I am running into the following exception:

      Marking servlet UserConfigService as unavailable
      /headlights threw load() exception
      java.lang.ClassCastException
      at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java)

      I have looked through the website forums and didnt see a solution to this issue. I have created the following files:

      1)webservice.xml
      2)config-service.xml
      3)web.xml
      4) Using wscompile I have generated the jaxrpc-mapping.xml and finally the wsdl file, I am showing some of the files below:



      webservice.xml
      <webservice-description-name>UserConfigService</webservice-description-name>
      <wsdl-file>WEB-INF/wsdl/My_UserConfigService.wsdl</wsdl-file>
      <port-component>
      <port-component-name>UserConfigPortComponent</port-component-name>
      <wsdl-port>UserConfigServicePort</wsdl-port>
      <service-endpoint-interface>com.adobe.esd.headlights.server.userconfig.webservice.intfce.UserConfigService</service-endpoint-interface>
      <service-impl-bean>
      <servlet-link>UserConfigService</servlet-link>
      </service-impl-bean>
      </port-component>
      </webservice-description>


      config-service.xml







      web.xml

      <servlet-name>UserConfigService</servlet-name>
      <servlet-class>com.adobe.esd.headlights.server.userconfig.webservice.impl.UserConfigServiceImpl</servlet-class>
      <load-on-startup>0</load-on-startup>




      Can anyone share some insight into this problem, is it a deployment issue, please let me know, I have looked through my deployment descriptors several times and dont see anything obvious.


      Any help would be much appreciated